Super key open rofi in Qwerty

Hello,

When I press the Super key it opens Rofi.

And I can’t debind it, in my rc.xml file it is not defined.

(What makes it even more annoying is that it opens it in Qwerty mode, while everything else in my configuration is in Azerty.)

Thanks for your help.

There is a line in your ~/.xprofile for ksuperkey. Comment that line out.

Welcome to the forum. Enjoy the distro.

4 Likes

Thank you :wink:

However I just did it and the binding is still working…

Did you log out / in ?

~/.xprofile is read when you start your X-session so that binding will be persistent until you log out/in.

2 Likes

Yes, I forgot to mention it.

Check in /etc/xdg/autostart/ for a ksuperkey entry.

As per this thread: ksuoerkey

:point_down: I don’t see any ksuperkey entries in /etc/xdg/autostart/…

Except for three gnome-keyring-*.desktop that :

$ Exec=/usr/bin/gnome-keyring-daemon --start --components=pkcs11

Maybe I should remove these .desktop (by making a backup first of course)? Or just remove the Exec = ?

No, leave those there; they provide different functionality - gnome keyring ArchWiki.

I’m not sure why that binding is persistent. Unless it requires an actual reboot to clear ksuperkey.

You can check some of the other autostart options like ~/.config/openbox/autostart to see if there is another entry for ksuperkey.

When I spam the Super key, I see that the xfsettingsd daemon goes up… Maybe it has something to do with that?

Could be. You can remove that xfsettingsd.desktop file. If you do, you’ll need to use something like lxappearance to set the gtk theme.

I just tried it and it doesn’t change anything ^^
Arf, this persistent binding bug me :sweat_smile:

:white_check_mark: Finaly ! I found it was in ~/.config/openbox/autostart

# ksuperkey -e 'Super_L=Alt_L|F1' &
# ksuperkey -e 'Super_R=Alt_L|F1' &
2 Likes