Strange nivida error

I have an “semi-old” workstation (homebuilt) with nvidia geforce gtx 560 and I had some trouble when I installed nvidia driver. lspci -v gives “kernel driver in use: nvidia”, but when I update kernel I get ==> ERROR: module not found: nvidia,' ==> ERROR: module not found:nvidia_modeset,’
==> ERROR: module not found: `nvidia_uvm,’
I am not at all sure whatś going on here!?
Anyone with similar errors?


1 Like

Have you tried ti disable kernel modesetting by any chance ! Might do the trick.

Also pretty sure that you had a look at this link already !

Edit: Is it after the latest update & do you have a black screen also !

1 Like

Hi and thanks for answer!
The thing is that I did disable modesetting when I installed nvidia driver and yes this happened after latest update but I have no black screen (thankful for that!).

Yep , lucky ! Don t know why it does so after updates/upgrades.

Also , do you happen to have had any issues with nvidia or it s someone else, couple of issues with nvidia on linux sadly.

Also, have the output in terminal of this one, might give us a clue somehow:

inxi -G

Edit: I would give bumblebee a shot , never know.

inxi -G
Device-1: NVIDIA GF114 [GeForce GTX 560] driver: nvidia v: 390.116
Display: x11 server: X.Org 1.20.4 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1280x1024~60Hz
OpenGL: renderer: GeForce GTX 560/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116

1 Like

Looks like it s there , but it doesn t work right !

Edit: Wonder if it can work again, been a little while back:

Edit: Looks like the updates screw your install somehow, weird. Might not mean that this solution that worked it the past might work today because of dependencies changes etc.


My God!

It worked again! Thanks for eminent help!


lol, no problem my friend, glad that it s resolved !