Strange "firmware module" error during every update


#1

Good Day Labsters,

I constantly get an error when I update, usually occurs at the end of the update and usually when there’s a kernel update. Below is the error message I see:

==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x

Where do I find these firmware modules?


#2

They may be in the AUR but you probably don’t need them:

https://lists.archlinux.org/pipermail/arch-dev-public/2013-May/024864.html

EDIT: try:

pacman -Fy
pacman -Fs aic94xx

#3

is firmware for h.d. western digital
try
yaourt -S aic94xx-firmware wd719x-firmware

[don@don-pc ~]$ yaourt -Qi wd719x-firmware
Nome                      : wd719x-firmware
Versione                  : 1-3
Descrizione               : Driver for Western Digital WD7193, WD7197 and WD7296
                            SCSI cards
Architettura              : any
URL                       : http://support.wdc.com/product/download.asp?groupid=801&sid=27&lang=en
Licenze                   : unknown
Gruppi                    : Nessuno
Fornisce                  : Nessuno
Dipenda da                : Nessuno
Dipendenze opzionali      : Nessuno
Richiesto da              : Nessuno
Opzionale per             : Nessuno
Conflitti con             : Nessuno
Sostituisce               : Nessuno
Spazio richiesto          : 15,00 KiB
Pacchettizzatore          : Unknown Packager
Data di creazione         : ven 17 nov 2017 08:41:07 CET
Data di installazione     : ven 17 nov 2017 08:41:12 CET
Motivo dell'installazione : Installato esplicitamente
Script di install         : No
Convalidato da            : Nessuno

[don@don-pc ~]$ yaourt -Qi wd719x-firmware 
Nome                      : wd719x-firmware
Versione                  : 1-3
Descrizione               : Driver for Western Digital WD7193, WD7197 and WD7296 SCSI cards
Architettura              : any
URL                       : http://support.wdc.com/product/download.asp?groupid=801&sid=27&lang=en
Licenze                   : unknown
Gruppi                    : Nessuno
Fornisce                  : Nessuno
Dipenda da                : Nessuno
Dipendenze opzionali      : Nessuno
Richiesto da              : Nessuno
Opzionale per             : Nessuno
Conflitti con             : Nessuno
Sostituisce               : Nessuno
Spazio richiesto          : 15,00 KiB
Pacchettizzatore          : Unknown Packager
Data di creazione         : ven 17 nov 2017 08:41:07 CET
Data di installazione     : ven 17 nov 2017 08:41:12 CET
Motivo dell'installazione : Installato esplicitamente
Script di install         : No
Convalidato da            : Nessuno

[don@don-pc ~]$ 

#4

Thank you for the replies. Do I really need this firmware and should this warning worry me?
I’m apprehensive when it comes to installing drivers from the AUR…


#5

I have them installed, but you can do well without it, the only thing is that when you update the kernel, you will have the warnings


#6

OK cool, thank you for the advice and input. I think I’ll play it safe for now and leave the system as it is


#7

Just to finish this thought, both are in the AUR and can be installed with baph if a user wants/needs them.