Steelhead (hatchery testing) Development

May have to wait. @cog mentioned there’re some issues in Debian installer for bookworm.


The stable hatchery has expert mode I believe, steelhead doesn’t, only calamares until the Debian team fixes d-i.

I’ll look into it.

UEFI is not available for me. I wasn’t sad about that all these years.

If I may add my two cents:
I find testing inconsequent. Fixed packages arrive there nowhere near as continuously as in sid(uction). And this especially from the point of view of pipewire and iwd discussed here.


I completely agree with you. Because of the steady stream of packages stuff doesn’t get broke and then frozen and broke on Sid.

This iso is just to be able to get ready for the next stable release.

1 Like

Thank you @cog, you are the boss of this wonderful ISO. I had not understood the purpose of ‘steelhead’ for you. Sorry for that :wink:

Maybe it is of interest for one or the other, how to install pipewire in hatchery as a replacement for PulseAudio. I did that earlier with ‘copy at siduction’ here. It is quite simple:

We need the following packages, if not already present:
(libspa-0.2-bluetooth | if Bluetooth is desired later)
(libspa-0.2-jack | if the sound server JACK is planned)

the setup to replace PulseAudio with PipeWire:

sudo touch /etc/pipewire/media-session.d/with-pulseaudio
sudo cp /usr/share/doc/pipewire/examples/systemd/user/pipewire-pulse.* /etc/systemd/user/


systemctl --user daemon-reload
systemctl --user --now disable pulseaudio.service pulseaudio.socket
systemctl --user --now enable pipewire pipewire-pulse

check with

pactl info | grep '^Name des Servers'

the command should return this: Name des Servers: PulseAudio (on PipeWire 0.3.19)
If this output does not persist on reboot (I did not have to do this in siduction. I had to do it here in hatchery) then the PulseAudioSevice must be masked:

systemctl --user mask pulseaudio

and check again with a reboot.

finally the setup of alsa-clients

sudo touch /etc/pipewire/media-session.d/with-alsa
sudo cp /usr/share/doc/pipewire/examples/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/

Setup of JACK

sudo touch /etc/pipewire/media-session.d/with-jack
sudo cp /usr/share/doc/pipewire/examples/*.conf /etc/
sudo ldconfig

That’s it. These two commands will help if something is not running:

systemctl --user status pipewire.service

and if necessary

systemctl --user restart pipewire-pulse.service



@unklar thanks for the install tutorial. much appreciated.

@chroot you were right. I just uploaded a new steelhead-012723-amd64.hybrid.iso with wpasupplicant intalled. Wireless was rocking and rolling for me with the update.

Edit: @unklar we can script in bios boot as defaut with uefi fully supported on top with the Siduction way, but it will take a little bit :wink:

As of right now I think want to include calamares and Debian installer both on the next stable release.


Thanks go to @devil, the admin and founding father of siduction. :+1:

So finally I am installing steelhead on the main rig. On my third install now, mostly because I’m trying lots of different stuff.

At this point I’m blown away with calamares, I can do a LUKS install without the bs unencrypt delays (if you manually partition) That was my old beef with calamares.

Would anybody be apposed to going full blown calamares and ditching Debian installer for the next stable release? (This would be on the bookworm base, not bullseye)


iwd will be a no-go on the bookworm base. We’ll definitely be going pipewire tbough. Iwd+nm still has connection amnesia. Pipewire works good tbough. I’ve tested this a lot on Arch and gentoo in the past year, nothing magically changed on Debian.

There’s nothing wrong with trying this with calamares, although debian-text-installer has grown on me lately.

There are still the following hints to consider and I don’t know if you know them:

Remove Non-Free:

Currently, the installer does not offer the possibility to deselect packages that do not comply with the DFSG, the Debian Free Software Guidelines. This means that packages such as non-free firmware are installed on the system by default. The vrms command will list these packages for you. You can remove unwanted packages manually or all together by typing apt purge $(vrms -s) before or after installation. Otherwise, our remove-nonfree script can do this for you at a later time.

Installation notes and known issues

If you want to reuse an existing home partition (or another data partition), you should add it after the installation and not in the Calamares installer.

With some older Intel graphics processors on some devices, the system may freeze shortly after booting into Live. To fix this, you must set the kernel parameter intel_iommu=igfx_off before booting again.


Installing iwd

I myself have not used it so far, as my machines in question are set up with systemd-networkd.

Everything works now.


Running on the latest steelhead iso with no issues, install was good on a basic setup.
Great work !



I’m thinking about doing an eww pop up welcome dialog just so someone can click, install now which would fire off calamares or hit continue with the live session.

I just uploaded an 012923 steelhead iso. @unklar your bios boot install stuff should be handled automatically by calamares now like siduction. As long as you’re connected to the internet, it should be trouble-free.

This iso also addresses some firmware stuff as debian bookworm just created the “non-free-firmware” repo component. It fixes firmware-sof-signed namely what’s been tested.

The next iso will be mostly cosmetic. A splash dialog to launch the installer or just use the live-session. Also hatchery theming in calamares.


when i try to install the latest steelhead iso in gnome-boxes, calamares installer says that i have not enough space to install it, at least you need 3 gb there is marked when i have 21.5 gb for it?

1 Like

I’ve been testing in gnome boxes too. Does “sudo” calamares make a difference??

My experience was that checks would fail if not run as root like it expected.

still no luck, now it says not connected to the internet

Think I will stay on riogrande prefer stable with Debian. And source install most of the programs i use.


1 Like

Same thought here.