Steam not launching after nvidia driver installation


#1

Heyo,
First post here (and hopefully the last one :P)
For some reason, Steam refuses to open with the following output:

taavi@laptop ~ $ steam-runtime 
Running Steam on archlabs x86_64 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!

I tried to run steam-runtime with strace, but it did’t help.
Any ideas? :smiley:


#2

I hope not!

Have you checked the arch wiki section on Steam? https://wiki.archlinux.org/index.php/Steam

Does steam-native work?


#3

(last one as in last issue haha)
I read the Steam section in the Arch Wiki and there was no solution though, i will try the flatpak installation next.

steam-native “says” it needs the following 32-bit libraries:
libgobject-2.0.so.0
libglib-2.0.so.0
libgio-2.0.so.0
libgtk-x11-2.0.so.0
libpulse.so.0
libgdk_pixbuf-2.0.so.0
libva.so.1
libva.so.1
libva-x11.so.1.

i tried to search these libraries on arch packages but i couldn’t find all of them though.


#4

The install section tells you you need multilib enabled.

Enable the multilib repository and install the steam package.

The following requirements must be fulfilled in order to run Steam on Arch Linux:


#5

I have enabled multilib and installed steam from there.


#6

I think what Dobbie is also stating, that there are pre-reqs that need to be installed (mainly the OpenGL) . I read that as in addition to. So you may want to verify that the programs mentioned are indeed installed.

Just a guess of course :slight_smile:


#7

Okay bizarre happenings here.

Did you install the nvidia drivers after steam? Is this something nvidia requires?

I’d be interested to see if the flatpack option works.


#8

Steam worked before the nvidia driver installation though and as i said i can’t find some of the libraries from the arch repository.


#9

Hey @Taavettii check this


#10

This too

https://bbs.archlinux.org/viewtopic.php?id=233695


#11

LOL - you be Faaaast!


#12

Well NVIDIA s not much friendly on Linux sadly. Too bad , wonder if you remove nvidia driver(s) what it will do.

I would also post results from this command in terminal; never know, might help somehow.

inxi -G


#13

I haven’t had a nvidia GPU for well over 10 years. ATI all the way. Never had any issues with ATI on Linux. Countless issues with nvidia.


#14

Good call @Dobbie03


#15

inxi -G output:
Graphics: Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 415.18
Display: x11 server: X.Org 1.20.3 driver: modesetting,nvidia
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 415.18


#16

I checked that and it’s not the same issue :smiley:


#17

I would try to use Intel s gpu, might not be the best but might work on your side @Taavettii


#18

Damn. Can I suggest falling back to open source drivers?


#19

The nouveau drivers?


#20

Yes. See if that works.