Spotify is not installed! [Solved]


#1

Hi everyone!
I did a new installation on a laptop, and Spotify is not installed in spite of my choice (yes) on the al-hello window. I tried to find Spotify in Pacman, there is nothing:

But, it’s very strange because from another computer (old install) i find Spotify:

Do you know why? And how can i install Spotify? Please, don’t forget, i’m a newbie on Arch system! :rofl:


#2

It couldn’t be simpler

yaourt -S spotify

#3

There is an error (erreur in french!):

There is 404 error from a package .deb (strange, it’s a Debian package!)


#4

Read the comments here:

https://aur.archlinux.org/packages/spotify/

When you have an issue with an AUR package, it’s always best to head to the AUR package’s page first for any info that may be posted. :slight_smile:


#5

Thank’s for your help Dobbie03, but what i have to do now, because It worked before with the al-hello?


#6

Either follow the instructions in the comments from the link above. Or wait until the maintainer is back from holiday and can update the PKGBUILD :slight_smile:


#7

Holidays are very importants! :grinning:
Ok, i’m going to wait. It would seem that Spotify does not want to develop a package for Arch Linux system. It’s sad like this capitalist world!


#8

It’s not that they don’t want to develop for Arch, it’s just that the PKGBUILD is out of date :slight_smile:


#9

Thanks Dobbie03. Arch is an interesting adventure! :wink:


#10

Yes it is. Treat her right and she will be more reliable than any other Distro. (disclaimer: I haven’t tried Gentoo properly or LFS)


#11

There’s an updated PKGBUILD in the comments on the AUR page:

https://bpaste.net/show/a241a3b530e7

My tutorial from BunsenLabs should also work in ArchLabs:

https://forums.bunsenlabs.org/viewtopic.php?id=3168

No need for backports in ArchLabs though :slight_smile:


#12

I’ve downloaded the packagebuild and i followed this Howto:
https://arashmilani.com/post?id=85
But i have this error:
curl: (22) The requested URL returned error: 404 Not Found
==> ERREUR : Erreur lors du téléchargement de http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.77.336.g0d3547d9-38_amd64.deb
Abandon…


#13

^ You’re still using the outdated PKGBUILD, copy the one from my link instead and try again.

EDIT: actually, looking at the PKGBUILD you should probably install it with flatpak instead, that AUR package just copies the binary from a .deb…


#14

Take this to install spotify. Install it manually. Works perfectly fine.

spotify installer

Cheers


#15

Thanks ruein, but what i have to do with your package?
There is a usr directory in your package, i have to copy manually on /usr? And how have to run Spotify, with a shell? Sorry for my question, i’am a very big newbie on Arch system! :thinking:


#16

Hi.

You install it with right clicking it and install with packagemanager or via terminal :

sudo pacman -U spotify-1.0.77.338-2-x86_64.pkg.tar.xz

Google and ArchWiki is your friend:)


#17

Thank’s a lot ruien, it’s solved! i did a right click with packagemanager. It’s funny, Pacman, Yaourt…:wink:
Google is not the friend of everybody, because apparently I am not the only one to have this problem:
https://plus.google.com/u/0/+MorenoSaragoni/posts/NnCa8UFzzSB


#18

@Jambalak, that’s the old version.

To get the new version use these commands:

mkdir ~/aur
cd ~/aur
git clone https://aur.archlinux.org/spotify
cd spotify
rm PKGBUILD
wget -O PKGBUILD https://bpaste.net/raw/a241a3b530e7
makepkg -sri

Then to update the package in future use:

cd ~/aur/spotify
git pull
makepkg -sri

We don’t need no stinkin’ Yaourt :stuck_out_tongue:


#19

Still thank’s a lot Head_on_a_Stick, there are a lot of cool men (and women?) in Archlabs forum!


#20

Nice!

@Jambalak can you please select the post that solved your issue? This places a link in your initial post so others who have this issue can solve it easy enough.Screenshot_2018-04-02_06-52-36

Its the tick box that is shown above.