(Somewhat urgent) Booting issues: 'Loading initial ramdisk...'

Okay, so after having trouble installing archlabs, I’ve run into a new set of problems. I could boot for the first few times on install, but then I just couldn’t. All options would freeze at “Loading initial ramdisk”. I’ve tried nomodeset, putting '3’at the end of the lines in grub, booting to a terminal and updating the system, and nothing has worked.

I’ve seen a reddit post on this, put have no clue on what it means or how to follow the steps. Any help would be great! Thanks in advance…

Reddit post steps:

  1. Loaded into latest archlinux iso.
  2. Mounted filesystem having issues with linux kernel
  3. arch-chroot for instance into /mnt
  4. pacman -S linux-lts
  5. rebuild everything under /etc/mkinitcpio.d via mkinitcpio -P
  6. grub-mkconfig -o /boot/grub/grub.cfg

So your system will actually boot but the desktop doesn’t load?

Can you switch to a TTY (agetty) screen with <Ctrl>+<Alt>+F3 (after the “freeze”)?

What is your video hardware & drivers?

Specs: CPU: Intel Celeron N3060 GPU: Some kind of Integrated Intel chip (I’ve tried looking but can’t find specific model) RAM: 2GB DDR3 Wrapped up in an Acer Cloudbook 14

@anon42040838 I can boot froom a live version, what i’m doing at the moment. I can sometimes (it only happened once) boot to a terminal of sorts when I put ‘3’ after ‘quiet’ in grub, and then sudo pacman -Syu, and it’ll then boot to a destop, where everything is working fine, but this only worked once.

I couldn’t open a tty screen…
Thanks for replying, was kind of worried for a second.

So you finished the install process properly, mounted and installed on the right drive etc. and then what. You rebooted and this happened? Or you rebooted, installed some apps and then this happened?

I used to get this error on some distros when using LUKS/LVM2. i.e. basically disable using cyrpt and it I didn’t get the issue. It sounds to me like you’re just getting the generic error where you can’t put in your encryption password and therefore can’t see the next prompt past the error you’re currently getting.

So in addition to what I already asked, did you also opt to encrypt your install?

@Cursewords Okay, so I installed archlabs from a love usb, then I shut down, unplugged my USB stick, and rebooted. Then, I am greeted with a grub screen. I select Archlabs (initrd) and boot up to a desktop. All is well, so I install a few apps, do some stuff, then shut down for the night. Wake up, try to boot up, and fail. As mentioned, I tried nomodeset, ‘3’, and yeah…

Also, I didn’t opt to encrypt my install. I am bamboozled…

Well I think it comes down to what did you install? I think something you installed broke your config. You could opt to try installing the LTS kernel instead next time. I’m having my own problems but namely with Openbox not working after installed my graphics drivers. Still, this sounds like you just changed a config somewhere and broke the install. It’s pretty common if you aren’t used to using linux.

I have re-installed a number of times, and the problem persists, so I don’t think the apps were the problem. I know how much of a noob I am, but how would I install the LTS kernel? By the way, are you using 3rd party graphics drivers?

Yeah I’m using Nvidia drivers but this time I’ll use i3 instead of Openbox. I initially wanted to use i3 anyway. Seeing as the issue seems to be with Openbox I doubt it will persist.

Getting stuck at the place you are sadly doesn’t give much info because a lot of things can cause that to happen.

You could try the flag:

IMSM_NO_PLATFORM=1

I found the thread that you found here: https://www.reddit.com/r/archlinux/comments/58an6s/stuck_on_loading_initial_ramdisk/?st=jhqnakhf&sh=9ae30f3b

Basically the suggestion is also to use the LTS kernel. Either the kernel was updated and it caused something to break, or something happened to the bootloader. I would suggest using the LTS Kernel.

It is an option to select it when the welcome script runs for the first time. Whilst finishing the script it says “Switch to LTS Kernel?” type “y” and enter. It’s the last option.

Good luck.

I had similar problem with my integrated intel graphics recently. Try the following steps:

  • press ‘e’ in the grub menu

  • at the end of the line having ‘linux’ write systemd.unit=multi-user.target

  • [CTRL] + X to boot and you should get a tty-login prompt.

  • login and downgrade mesa package from 18.0.4.1 to 18.0.3.1

  • add mesa to pacman ignorepkg

  • reboot and you should be able to get into your xsession

1 Like

@Cursewords @pangolin Thank you both so much for helping me, unfortunately I tried both of your soloutions, and combined them, and i’m afraid they didn’t work, so I’m just going to search for an alternative distro.

Thanks again,

Syrup

I’m really not sure what the issue is but perhaps just a rebuild and reinstall a couple things from a chroot.

I had a similar issue about a month ago, went to bed, next day my pc just wouldnt boot. I left it on the black screen for a bit and it finally spit out an error, it was a failing fsck, less than a week later my 3tb drive was dead and while it was dying it made the whole pc feel like it was dying

Just quoting my directions from another recent post,