Some installation issues

I’ll start by saying I am new to Arch (and to linux in general, having so far only used Kubuntu for about 5 months)

I decided to give Arch a try and found ArchLabs, which so far I’m digging, as it’s pretty intuitive and certainly more straightforward than something like ArcoLinux.

I managed to install it on my laptop (a Lenovo Ideapad C340), however I managed to screw up something in LightDM, and after a few attempts at fixing the issue through installing and enabling other DMs via TTY, all of which failed, i decided to reinstall the OS entirely.

Only this time, i’m getting some weird mirror/repo issues.

I suppose the default mirror went down and an alternate one was used, since the installation went through eventually (though it’s worth noting that i initially tried selecting LightDM, which caused the installation to fail, i fixed the issue by selecting xinit instead and enabled auto-login).

Also worth noting that the same issue occurs on an installation attempt on VMWare, hence the screenshot.
As for why i’m updating the installer in the first place, it’s because of this:

Imgur
-another VMWare screenshot, but the issue occurs consistently even on actual installations if I don’t update the installer (the ISO version is 2020.05.04)
-had to upload this via Imgur due to new user restrictions

Anyway, installation issues aside, once i managed to get into my bspwm session by using xinit instead of lightdm, i am greeted by this when trying to query arch repos or install AUR packages via makedir -sri:

Imgur
(no utility to make a proper screenshot unfortunately, since i can’t even query for flameshot, let alone install it, sorry)

What’s weird is that I’m not getting the issue on my VMWare install, i can query and install programs
just fine.

So…any help would be appreciated :slight_smile:

Seems like an outdated mirrorlist try something like

reflector --verbose --latest 200 --age 24 --score 75 --sort rate --fastest 6 --save /etc/pacman.d/mirrorlist

Done, ran the command before the installer and everything works just fine now. Thanks!

Just curious though, why exactly did this happen, considering the mirrors worked well two days ago?

Glad that you got it installed @Cassiel .

Maybe a mirror update.

Please mark it as solved as it might help other members in the future.

Things change, mirrors go down or get out of sync. Sometimes they work for a long time without issue, other times you need to update it days apart, 404 response is a good indicator you need to update them.

Please mark the post as solved by checking the little box to indicate the post that solved your issue, this helps others searching for the same issue find the solution faster.

Cheers

1 Like