ArchLabs Linux

Some fonts to bold and to big

Ok, so first, I apologize if this was already asked, I searched the forums, but there doesn’t seem to be users with the same problem … so my problem is the following …

I use NVIDIA propriatery drivers, once I install them, the drivers start reporting the real DPI of my screen and all fonts increase to that DPI, which is fine, and kinda what I want, but, some fonts, are to bold and to big … I understand that ~/.config/fontconfig/fonts.conf is used to apply system wide font settings, but no where in there did I find the size / bold settings … so let me show you exactly what i mean by that

here are some screenshots:

the screenshot bellow, is before installing my NVIDIA propriatery drivers

then the next one, is after installing my NVIDIA propriatery drivers

a big difference in size right?
now, after installing the drivers, some fonts are very beautiful, and some are extremly ugly, big, and unreadable


this is what it looks like once i install microsoft core fonts, since this last example is from chromium, and chromium uses those fonts by default


they are normal sized, compared to all other fonts

look at the thread titles vs text in the thread, they are huge, like crazy huge, i understand that in /etc/fonts/conf.d/ are symlinks to fonts settings, but which one is that bold ugly at least 2x the size it is supposed to be? and what part of the xml do i need to edit to change that? Not a expert at xml … I want all fonts just to be in their default sizes, not 2x, 3x, etc … can anyone help me with this?!

Wonder if it s nvidia the cause here.Please post output from terminal;

inxi -G

Some applications won’t respect the reported DPI, see here for some general tips.

1 Like

What HoaS said, I generally just set mine via Xresources https://wiki.archlinux.org/index.php/HiDPI#X_Resources

Graphics: Device-1: NVIDIA GK106 [GeForce GTX 650 Ti] driver: nvidia v: 430.40
Display: tty server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 650 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40

I don’t think it’s the nvidia driver anymore, I just did a bare arch install on a 2nd partition, with the same terminal, also i3 gaps (LARBS actually), thigs look pretty normal … so … what could be enforcing such scaling?

here is a SS for comparison (will edit and upload one from ArchLabs a little later)

hm… interesting … I solved the problem by reinstalling / installing packages … this is what I did …

sudo pacman -S adobe-source-sans-pro-fonts --noconfirm
sudo pacman -S cantarell-fonts --noconfirm
sudo pacman -S noto-fonts --noconfirm
sudo pacman -S terminus-font --noconfirm
sudo pacman -S ttf-bitstream-vera --noconfirm
sudo pacman -S ttf-dejavu --noconfirm
sudo pacman -S ttf-droid --noconfirm
sudo pacman -S ttf-inconsolata --noconfirm
sudo pacman -S ttf-liberation --noconfirm
sudo pacman -S ttf-roboto --noconfirm
sudo pacman -S ttf-ubuntu-font-family --noconfirm
sudo pacman -S tamsyn-font --noconfirm

it seems to have overwritten some settings in fonts/conf.d/ and everything is now decent