[Solved] Where is the resize mode? Rofi entry bug

Hello! I have a few problems. One of the things that is bugging me is that I can’t resize some windows $Mod+r is not activating the resize mode. Also there is a problem I had in past distros. After I install and uninstall intellij there is still it’s entry in dmenu/rofi. Shift+del doesn’t seem to work so how can I remove it?

Did you enable float before attempting, the $Mod+r shortcut for resizing a window?

Yes but the thing is that I can’t find the $mod+r shortcut in the i3 config.

Here you go.

But if you want the functionality that you described you can always do it by adding something like those lines in your i3 config:

bindsym $mod+r mode "resize"
mode "resize" {
        bindsym j resize shrink width 5 px or 5 ppt
        bindsym k resize grow height 5 px or 5 ppt
        bindsym l resize shrink height 5 px or 5 ppt
        bindsym odiaeresis resize grow width 5 px or 5 ppt

        bindsym Left resize shrink width 10 px or 10 ppt
        bindsym Down resize grow height 10 px or 10 ppt
        bindsym Up resize shrink height 10 px or 10 ppt
        bindsym Right resize grow width 10 px or 10 ppt

        bindsym Return mode "default"
        bindsym Escape mode "default"
}

This will set your $mod+r keybind to enable resize mode and after that you can press the arrows or j-k-l-o to resize your window. When you are done you press Escape or Enter to go back to normal mode.

Thanks! Sorry for the late reply tho.

After I install and uninstall intellij there is still it’s entry in dmenu/rofi. Shift+del doesn’t seem to work so how can I remove it?

Have You tried to remove dmenu & rofi cache from ~/.cache folder?

Some applications create .desktop files in various locations, after uninstalling they arent removed, usually because they are in your home folder somewhere.

I’d look in ~/.local, ~/Desktop, ~/.config
Failing this try looking in /usr/share/applications

I use i3 myself and I personally dont really like modes,
theyre messy and make you use (at least 5 keys) to do a single action requiring only 2 keys
that being said I know i3 uses resize mode by default.

I suggest making your own config and be done with it

i3-config-wizard

Cheers

1 Like

@Viktor, thanks for your post. In future please title your threads to make more sense to the question you ask. Also to make searching for fellow users who may have the same issue, please keep to one topic per issue.

Thanks

Ok! I guess I have to rename it and put solved right?

MIght as well :slight_smile:
Thank you.