*SOLVED* Swap file?

I might have missed something but during the installation I was only offered to have a swap file or not. Normally I use a swap partition for this. I needed to manually add this swap partition to fstab after installing. Is there a reason to not give the option to select a swap partition?

1 Like

@wammes Perhaps you simply missed it. After testing the installer extensively and on three separate machines, it’s never failed to recognize my swap (when I’ve used one). It will detect a swap partition and prompt you to confirm but does by size (7.95gb in my case) not by drive and partition (dev/sda2 for example). It prompts for your confirmation, right after formating and mounting / and where to write grub (boot).

It happened the same here, on 18.03, 18.05 it was possible to create the partition, with this release was not possible, I tried twice and left the system with the swap file, the installer only asks if you want to use swap or not, even pointing to partition it creates the file and uses this, also did not see the image viewer and my terminal takes a long time to show the characters

I hope it is possible to visualize, and the process goes up a lot as shown in polybar
Video: Terminal

@m.rogers The installer gives you the option of editing partitions, prior to formatting and mounting them. Simply create one then or before running the installer using gparted. If you already have a swap partition, the installer prompts you to utilize it.

Sim, eu fiz isso, o processo é o mesmo das outras edições mas o instalador não se deixa escolher uma troca de partição, ele simplesmente decide por você … pelo menos aqui foi assim, duas tentativas de instalação e na terceira saída do modo que esta , preciso da máquina, só estou com essa no momento

See, the partition is not in use, it does not appear in a single command, only the swap file.

1 Like

Detail, the partitions were created at the time of installation, it was not before or after … no problems, it works fine, it’s just an account, ABIF has changed a bit …

1 Like

I don’t normally use a swap but decided to for this install on my desktop…

So, I don’t know.

1 Like

Note that your swap partition is inside an extended partition and has a padlock next to it indicating recognition, mine was created as (supposedly) a primary partition (default) and should be the same, but the installer did not give me this option.

1 Like

Yeah and funny thing is, I normally don’t bother with swap but for testing purposes, I’ve recently been using one and haven’t had a single issue. Sorry @m.rogers, wish I had a better explanation.

1 Like

Do not worry no need to apologize :grinning:
It’s just an account like I mentioned, there are no problems, so my use does not make big differences if it’s a file or a partition, but the fact is that the installer was not shared as in other editions of AL, just that.

1 Like

In my case that was not true. I had a swap partition from a previous install of 12G. The installer did not offer to use it.

It did not give me the option. The swap partition existed. Was also ‘labeled’ as swap because it was used as one on a former install. I did not create partitions because I already had them setup for distro installs. /boot / and /home went fine. Swap did not. It’s not a big deal to add it to fstab manually but for new users it can be a pain.

1 Like

I found it strange because with any other installation I indicated the previously created swap partition and it is used, but this time it did not happen.

2 Likes

Re: swap & installer

It was just removed during a large rewrite and never added back in, I didn’t see it as a serious issue and other things were more important to get working first. Currently if you want to use a swap partition you have to set it up post-install. After seeing this I’ll set it back up for next release, though I still recommend using a file over a partition. The installer has (and will continue to) go through major changes and rewrites this is just something people will have to deal with.


Re: terminal issue

@m.rogers open ~/.zshrc in an editor and remove this line near the bottom of the file

[[ ! -e ${ZDOTDIR:-$HOME}/.zshrc.zwc ]] && zsrc &>/dev/null

If the issue still persists then it’s likely in the al-info script, perhaps your hardware etc. You can try to find the problem if you like, the script is /usr/bin/al-info

Try running it with set -x

set -x
al-info

will output each line before running it, might be able to see where its getting hung up. Simplest solution is to remove the line calling al-info in ~/.zshrc.

2 Likes

@natemaia Ok I’m a little confused. Prior to yesterday, I had four ext4 partitions on my drive. One for my main AL installation, three I created for testing AL and a swap partition for that purpose. I removed all four ext4 partitions yesterday but left the swap, then reinstalled AL on a fresh partition. The installer recognized the swap and the above gparted image shows it was mounted. Looking again just now, it’s no longer mounted. So a Ghost in the Machine? I don’t get it.

Thank you for your help!!

When I reported these details I was already in search of the solution of the terminal and after cleaning the cache and updating the system everything returned to normal, I got to verify the hosts file to see if it had any undue block, once I installed a program that makes changes on hosts and browsing was poor, but it was not that and now it’s in order.

On swap, it really is not a problem, but it is a matter of habit, after years of exerging options to create or not the file or partition swap any one gets confused, previous installations show us options to choose and point the file or partition.

I want to thank you again for your willingness to help, thank you!!

Ok, having finally been able to get back on my desktop (bad weather). The swap partition I created and left is not mounted. Confirmed both by gparted and fstab. Why gparted reported it as mounted the other night, I’ve no idea. So, you guys were right.

I still don’t understand why I was prompted by the installer for swap and others weren’t. Maybe I’m going off the final bend, who knows :thinking:

When did you check to see if it was mounted? The live session may have recognized a pre-existing swap partition and mounted it during boot. If I understand it correctly, the dynamic swapfile is not activated until the system is rebooted and the previous partition would not be mounted.

After reinstalling a couple days ago and only because of this thread. I normally don’t use swap but created the partition when testing the various testing releases recently. I couldn’t have mounted the thing manually, even I would remember doing that. Yet, there it is… Mounted.