[Solved]Screen tearing and obmenu

Hello,
I am experirncing two misbehaviour of my OS; the menu switcher doesn’t switch and the screen is tearing in web browser (no more once i disabled smooth scrolling)
I have switched to PCManFM and the menu (‘Places’ section) is still stuck with Thunar.
At the same time new programs are listed in the menu after being installed.
I know i shouldn’t be posting this in this category, but this ‘issue’ is not a big deal for me, so i don’t want to trouble anybody this weekend.
Sorry for that.

Hi @pippo, p[lease try to keep to one issue per thread.

Okay, lets sort this out.
a) how did you se PCmanFM as default?
b) are you using the obmenu generator generated menu rather than the static menu?
c) have you installed obmenu generator or uninstalled by mistake?

Hi Dobbie,
1)Sorry
2) Already up or still haven’t go to bed? Ok none of my business, sorry again.
This is what I’ve done:
a)Install PCmanFM
Unistall Thunair
Selected PCManFM in the Preferred Applicaton window.
b) I am using the obmenu generator the static menu is currently unreachable.
c) when i realized it didn’t switch i run al-hello and selected the dynamic menu option, of course nothing happened.
Thanks for the prompt response

Alrighty. FIrst off, no need to apologise. Yes, I have been to bed, it is now Sunday 4th March, 9am :smiley:

You may need to edit your menu.xml and rc.xml and replace thunar with PCmanFM.

Try deleting the menu.xml generated and replacing it with the default. Found here.

If you have no need for obmenu-generator, just uninstall it.

1 Like

Thanks for the help, and for moving the topic to the right place.
Have a nice sunday.
If i figure out how to mark it as solved i’ll do it

1 Like

For the menu switcher, change the command in ~/.config/openbox/menu.xml

For the generated menu

switchmenu --dynamic  

Switch back to default

switchmenu --static

Apologies for this one

1 Like

For this one your gonna need to edit the script

/usr/bin/al-places-pipemenu

Copy it to ~/bin/al-places-pipemenu so you can edit without needing to change the default
scripts in there will be used first before searching other locations on the PATH

Edit the following, changing the commands as needed

readonly terminal=termite
readonly text_editor=geany
readonly open_folder_cmd=thunar

In your case would be

readonly terminal=termite
readonly text_editor=geany
readonly open_folder_cmd=pcmanfm

Cheers

3 Likes

Thanks guys, all back to normal now.
Sorry for the late reply, but I sleep a lot.
Thanks again :love_you_gesture:

1 Like