(solved)New AL install - Some fonts way too big

SO i had some shutdown issues on this box, after no fix finally did a new install AL. Twas going swimmingly good. I am not a 100% cognitively there, but anyway I was tweaking the install hardcore ie grabbing my fav configs, uninstalling, installing, had wayyyyyy to many windows open @ once and BAM Most of the fonts are al the sudden HUGE . i was able to switch most back by switching themes etc.

here is where I am at:
termite fonts ok
all openbox windows are way too big, but it seems like gtk3 fonts inside are ok, gtk2 program fonts too big.
Xfce Windows ie settings , appearance too big
any cli programs font ok
I think kodi might be off larger but its usable
gimp too big (assume its gtk2?)
polybar and tint2 good
I was switching nvidia from apparently nouveau at this time as well

i could just reinstall but honestly at this point I’m bonking hard and this is my vegout entertainment center. I haven’t got the energy to re tweak this box full on.

I think this involves 1 or more of the following
xfce settings
gtk2 settings of some sort

I think I’m just not seeing something, forest in the trees sort of thing. I’m hoping someone might have a light bulb moment and say “hey check this out dumbass” heh. otherwise I’ll reinstall later when I feel better

thanks for any wise words/help

your pen pal fluffy

currently i changed the font size for OB to 6 and that’s better but still large

1 Like

What version are you running @FluffyUnicorn? Also, did you check your configs? Also check your dots to see if the configs for your fonts are correct. When I get to my machine, I’ll see exactly where the font configurator is.

july release, openbox

1 Like

@FluffyUnicorn can you do a uname -a and post the result. I’m guessing that you are using AL 2018.07 but I want to make sure.
if you are using the latest AL; just right click your mouse then scroll down to Settings. In the Settings menu click Appearance. When the menu pops up, just click Fonts tab. In this section you can change your fonts which ever way will work including font size.

You must have a setting buried somewhere in the configs you copied over/tweaked, best way to figure it out is to start at the beginning of the boot process and go from there.

Setting everything through xfce4-setting-manager doesn’t fix issues with gtk2?

Have you looked into wiping and re-generating your font-caches?

How do you login?

  • For xinit then you should check what is in your ~/.xinitrc, ~/.zprofile, ~/.xprofile, ~/.profile etc…
  • For lightdm check ~/.xprofile

Next you wanna check the WM configs as it’s likely the next thing that gets loaded

  • For openbox check each config in ~/.config/openbox (not just the .xml files)
  • For i3 check it’s config in ~/.config/i3.

Keep doing this until you either find the problem or are down to the application level, some things like gimp may have their own built in settings/preferences.

This won’t really matter, I highly doubt the kernel is gonna have anything to do with fonts, and it wont tell you what version of AL he is running as it’s rolling and the kernel is upgraded during install.

To get the ‘version’ of AL you can grep the ‘LSB_VERSION’ field out of /etc/lsb-release

awk -F'=' '/LSB_VERSION/ {print $2}' /etc/lsb-release

This likely isn’t reliable on older versions, but going forward this is the best way to get what iso version was used for install.

Thanks @natemaia. I was just going by memory and couldn’t remember the exact command I needed him to use. But after thinking about it, I don’t think I need that info. He should be able to use appearance to change his font. I’m wondering what dpi is he using though. I’m wondering if that is the culprit. :thinking:

1 Like

dracul@zombieland ~ % awk -F’=’ ‘/LSB_VERSION/ {print $2}’ /etc/lsb-release

I believe the dpi was ok, I did change it a few times whilst trying to fix it
I did go thru the openbox configs, but I actually had not transferred any of those over yet
I use lightdm but had not looked at .xprofile, ty for the info
Also I messed with fonts in both setting, lxappearance, obconf

It is apparently the nvidia-390xx driver on my old card, so instead of downgrading the xorg drivers as advised on the archwiki, I am trying the nouveau driver, so far so good. I haven’t tried a game yet, did hack a polybar config to show gpu temp using sensors, I have a Geforce GT 730. I think the lack of support by nvidia for newer xorg is why I was having issues shutting down as well. It reboots like a champ now! The flashing black screen I experienced from before and after install seems like a xorg/nvidia type issue.

my video card fan sounds louder, so i have to check into that

thanks so much for helping, I needed to occupy my mind from feeling crappy as I was experiencing alot of anxiety this afternoon, not helpful. so I hacked.

1 Like

This is probably your issue, you likely need to use the xfce appearance manager to set things, the two conflict.

My card is also from the 700 series of cards and the latest nvidia drivers work fine over here.

I just installed it and tried both the gtk2 and gtk3 versions as a possible detective tool/fix. neither helped

Ah ok, gotcha

1 Like

huh, yeah I think a few months ago I had some issues, until i went from nvidia to nvidia-390xx, o yeah and my card is listed the the legacy card list linked on arch wiki. Your a lucky man! I dont play that high of graphics games just xonotic or the like, so hopefully this nouveau driver will be ok.

o and thanks man, I really appreciate your time, both of yall.

1 Like

3 posts were split to a new topic: GPU Fan loud with no load