(Solved) My installation nightmares

Well at first I was thinking about continuing this thread


But I’d figure it would be better starting a fresh discussion… maybe… I don’t know. and I going to be as most exhaustive as I can possibly be :smiley:

So, computer: RBS 2018 with an intel i7-8550U and Samsung SSD nvme (M.2 PCIe)
In BIOS configuration, I disabled everything related to secure boot (at least I think I have). I tried disabling CSM encountering anything but utter deceptions -impossible to boot my usb flashdrive, pluging it just stall my BIOS- in the end I had to turn it on again selecting UEFI support only… I can’t find an option related to IOMMU, that doesn’t seem to be an issue on my end anyway.

Initially started with beta-2020.04.17, made my own partitions: boot, root and home


Yeay! (ugh wait n1p1 is ext4… I didn’t notice at the time, but lets continue anyway)
Except that when I tried to mount them I got this… :frowning_face:

To witch I reacted like… “meh f*** it, I gonna auto part”


But then… at mount time… :frowning_face:

for which I found this thread https://bbs.archlinux.org/viewtopic.php?id=212129
I don’t know if that’s relevant though… I did the mentionned commands to this result aaaaand that’s pretty much what I was capable of. I just wanted to point that out to you

I then dug a bit on the forum and found the beta-2020.04.25. Let’s start for the scratchest scratch possible. I read a bunch of stuff about partitioning for efi and SSD optimiztion on the Arch wiki because why not… I might be outdated.
Made the flashdrive with latest AL beta I could find here (using rufus-3.10 btw, if that’s might be an issue, who knows? not me, that did the job for 4 different Manjaro with no issues)
Booted on it with ease (using intel_idle.cstate=4 because razer laptop and kaby-lake fu***ry, and cow_spacesize=6G because I might succeed -Ho, such the hopefully fool I was- mounting and installing everything in the first go)
Started the archlabs-installer script only to get font-size, keymap, and wifi connection right then exit - yeah I’m lazy, sue me!
pacman -Syyu-ed only to get latest al-installer upgraded. ‘pacman -Syu base’ because I wanted to be sure.
Check that my SSD my indeed with a GPT.
Made my partition with cfdisk


Buuuuuuuut… installer’s not happy.

I can’t remember which type of partition he wants - A Windows one on the auto but that feels crooked, why is EFI system not working ?
So now I’m just drowning my sorrow away.


I think I might just got for what nate proposed and


Then refer myself to the installer script source in order to get all the packets I need… but I’m a bit tired right now, that’s gonna be a story for tomorrow
Or… Maybe you can help me make the mount stage work in the install script… I have not yet had the courage to check and try editing it myself

I hope that you had - at the very least - enjoyed the post (and the haircut) :smiley:

I, also, had a slew of problems with an attempted install on my gen 10 i5.I almost broke through with AL (the newest installer) when I omitted the use of swap, but for some reason when I logged in, my mouse kept freezing for minutes at a time. I then tried manjaro and endeavourOS got the same results (system locking, freezing).

Finally I decided I needed a working machine and arch was likely my issue… I ended up just installing MXLinux. What can I say. My wine box awaits… my other pc is still okay with AL.

I know this is not much help, but what the hey…

That’s quite a bummer… I will not give up on Arch yet though.
That fact that I installed manjaro without any apparent major issues gives me hope :smiley:

1 Like

The newer beta you found in another thread indeed has some issues, just built and untested for the fellow to try some things with wifi.

You just had the unfortunate case of updating to a version I had just pushed for internal testing which had this issue of not getting the correct count of partitions so it always thinks you have too few (I’m in the midst of rewriting/improving the partition list), apologies there but such is the way with the unstable packages.

If it’s any consolation it’s the weekend here and we’re working on getting a new release out to deal with the recent influx of issues due to the old age of the iso but we’re reworking the package/base install so testing is needed. We are working on it.

1 Like

Yeah, seems fair indeed :smiley:

No worries, though, that’s alright I’m trying installing from a beta found in a thread not related to my issues :grin:
I did because of the troubles with the one you made for Colson. (Described above) ¯_(ツ)_/¯

However:

:thinking: then… not updating might be the answer to my worries?

Well, here it is too, and I haven’t any plan for tomorrow soooooo, if you need a beta-tester, eventuality, some help fixing. :smiley:, my bash scripting skills are a bit rusty, hopefully the installer script is quite easy to follow and understand :smiley: (gg)

From whichever iso you like you should be able to update the installer now and continue without issue. That was fixed within 30min of it being pushed, just an unfortunate coincidence.

For the most part I tried my best to make it clean, it’s still a 3k line bash script though at the end of the day so not the greatest. A lot of it is just text in it’s defense.

I welcome the offer though if you find anything or would like to add something feel free to contact or just do it and make a PR, can always do testing by downloading your fork from a live iso like

curl -fSL https://bitbucket.org/archlabslinux/installer/raw/master/archlabs-installer -o /usr/bin/archlabs-installer

I’m sure you can find a “raw” link on whatever platform you like, even pastebin should work.


Back on topic of your install issue and beta testing, I’ll link an iso here and you can feel free to get back with anything that comes to mind or not and just use it to install.

1 Like

You can also just update the installer as you outlined above and that’s a perfectly fine method as well.

1 Like

:rofl: :rofl: :rofl: :rofl: karma’s a b****
ok… I’m going to burn the latest iso you gave here (because… lazy me) and give it another go.

From what I saw yesterday night I’d say

Especially for a 3k lines long script

Indeed I’m probably going to use pastebin to test any change I might add to the script. If I fell that my changes are relevant I’ll ultimately do a PR ofc.

By the way, I tried to say~… :stuck_out_tongue: I tried adding boot options to the APPEND field in the archiso_(sys|pxe).cfg files but that does not seem to work. I still have to edit the cmd line manually at boot time.
Am I doing something wrong ? I’m quite confused

well I still got this output with custom partitioning…

LOL leave it up to the drive makers to put a space in the device name (damn you samsung!!), I just pushed what should be the fix for it. If you can update and let me know?

Also of note, you can avoid root/boot selection (they need to be formatted and ready)

ROOT='/dev/ROOT' BOOT='/dev/BOOT' archlabs-installer

Depending on what bootloader is being used the files in use will be different, for most systems it will be the ones in efiboot/loader/entries/*

If you’re sure it’s syslinux and legacy boot then the head/tail configs are where to look.

:rofl: :rofl: :rofl: Samsung be damned indeed. Forcing us to hanlde limit cases :stuck_out_tongue:

Ah! I forgot these options, my bad, thanks to remind me of these

Since I deactived legacy support in CSM I’m quite sure it’s not, rufus uses syslinux though. I’m gonna dig on that if I ever need to reboot :slight_smile:

The fix is working btw. I’m currently choosing kernel and apps, I choose to use pacstrap since its the Arch recommended way.

Yea the pacstrap method is what we’ll be focusing on for the future as it means our isos won’t age so poorly. The copy iso bit is still in just to give the option of a faster install (until the iso breaks they both should result in an identical system).

Glad it worked though, apologies again for the issues.

1 Like

Ah I frogot, I noted a slight bug: the < Exit > option in the main menu wasn’t working. I had to ctrl-c in order to quit the installer

I didn’t try after having updated the script though

No problem man, thanks for the help… If I had wanted an easy install I would have went for ubuntu or manja :smiley:

2 Likes

Lemme look into it.

You just had the unfortunate case of joining in when everything broke, usually it’s nothing like this. I can appreciate the enthusiasm for broken shit though :wink:

1 Like

@natemaia should the google url above, provide a decent iso for me to break?

1 Like

Yeah i know, I had close to no issue (at least from the installer) with the my last installs a few years back. I was quite surprised in fact. But hey, that’s alright. Except few errors when Pacman tried to create temporary files, the install went smoothly.
Everything’s looks fine for now :slight_smile:

Thanks for the help Nate

1 Like

Time to tweek my install now :grin:

2 Likes