[solved]Local time date not correct


#1

Yesterday I bought new laptop and successfully install Archlabs linux. everything going to perfect except time.

when I type the timedatectl, result is this

timedatectl status 19:47:00

Local time: Tue 2019-01-29 19:47:30 KST
Universal time: Tue 2019-01-29 10:47:30 UTC
RTC time: Tue 2019-01-29 10:47:30

Time zone: Asia/Seoul (KST, +0900)
System clock synchronized: no

NTP service: inactive
RTC in local TZ: no

the problem is UTC time is correct, not a local time
now is 10:47 not 19:47

So I check the KST TIME ZONE on interned t
surely they are correct 10:47 even UTC OFFSET is same thing (UTC +9)

now I try to find the information like ntp sync and etc hopefully but I want to know what is the problem
why UTC time is correct and KST time is incorrect for me? even I live KOREA

when I enter the bios setting, time is correct 10:47
I’m searching and searching, but still don’t know What is the problem.


#2

Try

systemctl enable systemd-timesyncd.service
systemctl start systemd-timesyncd.service

Should enable time sync, you could also use ntpd instead https://wiki.archlinux.org/index.php/Network_Time_Protocol_daemon

see if this fixes the issue.

If not, may I ask are you multi-boot with other OS that may have different time settings, this is known to cause issues like this but it could be something else.

You can also switch to using localtime from the RTC if you prefer that way using

timedatectl set-local-rtc 1

#3

I have a laptop with a flat CMOS battery and this works for me:

timedatectl set-ntp on

#4

Ahh very nice, I’m guessing this enables the above service for you given its a *ctl command?


#5

I’m not sure tbh, I’ll check next time I’m booted with systemd.


#6

timedatectl set-ntp on work for me
thanks !


#7

Excellent!

And yes, Nate was right — the command enables systemd-timesyncd.service