[SOLVED] Keyboard backlight error


#1

Hello all,

I have just downloaded ArchLabs Minimo (7.28.18) and when I try to install on my Dell Inspiron Mini 1012, it hangs trying to start the keyboard backlight.
This is a known issue with this Dell model and recent kernels, and the normal workaround is that whenever the version of Linux you are using boots for the installation, you just run sudo systemctl mask systemd-backlight@leds\:dell\:\:kbd_backlight.service and that prevents it in the future.
However, ArchLabs is not getting even to the installation, and all that I get to see is the status updates, which predictably stop at “Starting Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight…”
Is there a way to fix this?

Thank you all,
KM6BXP


#2

Try it but I do not know if it works and a solution for ubuntu.

Removing file /var/lib/systemd/backlight/platform-dell-laptop:leds:dell::kbd_backlight 

and masking the service systemd-backlight@leds\:dell\:\:kbd_backlight.service with:

sudo systemctl mask systemd-backlight@leds\:dell\:\:kbd_backlight.service 

Posting so that others might search this up a bit easier.  Thanks

Edit

Or this, remember to update grub made the edit in / etc / default / grub
GRUB_CMDLINE_LINUX_DEFAULT=“quiet acpi_osi=’!Windows 2012’”


#3

Thank you, Ector, for your reply.

Apparently this has actually been an issue with the Linux kernel since version 4.1.3. Does anyone know where I could get a release of ArchLabs with an older kernel?

Thank you all,
KM6BXP


#4

So, you are saying you can’t even boot the ISO properly because of it trying to load the backlight service ?
Or you can boot and load the installation process ? I would say that chroot into the new installed system and disabling the service would the trick IMHO

edit: can you access the tty still ?


#5

Thank you, gazeka74, for your reply.

No, I cannot boot the ISO all the way and have ArchLabs fully install. I can get to the beautiful selection screen (Install ArchLabs/boot existing OS/memtest etc…), where I select the “Install ArchLabs” option, the computer shows me a ton of code that I don’t really understand, and hangs on the backlight service. The computer is still usable (for some reason the Ubuntu-based distros install and I can run the mask command on them before rebooting, but I want to try an Arch-based distro with Openbox like ArchLabs), but there is no way to my knowledge to convince it to not load the backlight service.

Thanks all,
KM6BXP


#7

Have you given the latest ISO a try (12/2018)?


#8

see if the work of this post works Iván Jiménez

https://bugzilla.redhat.com/show_bug.cgi?id=1253523

As suggested by man systemd-backlight@.service, booting with the kernel command line parameter:

       systemd.restore_state=0 

also avoids the hang.

I think that file shouldn't be created in this laptop because it doesn't have a keyboard backlight or any LED in the keyboard.

#9

Thank you all,

I have tried the new ISO and it hangs in the same place. So, how do I try Iván Jiménez’s fix? I thought that I would let the ArchLabs installation go as far as it could, shutdown the computer, and then use another distro (one that runs from the installation medium without installation) to run the fix, but it appears that AL never actually installed, i.e. when I rebooted I got back to the old OS. So how do I set systemd.restore_state=0 in the kernel?

Thanks all,
KM6BXP


#10

As per the Arch wiki (https://wiki.archlinux.org/index.php/kernel_parameters#GRUB):

GRUB
Press e when the menu shows up and add them on the linux line:

linux /boot/vmlinuz-linux root=UUID=978e3e81-8048-4ae1-8a06-aa727458e8ff quiet splash

Press Ctrl+x to boot with these parameters.

To make the change persistent after reboot, while you could manually edit /boot/grub/grub.cfg with the exact line from above, the best practice is to:

Edit /etc/default/grub and append your kernel options to the GRUB_CMDLINE_LINUX_DEFAULT line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And then automatically re-generate the grub.cfg file with:

# grub-mkconfig -o /boot/grub/grub.cfg

You might not need to do the second bit but you might as well as it’ll give good practice.

This may not work so please forgive me!


#11

Thanks to all,

I solved the problem by adding the line linux /boot/vmlinuz-linux root=/dev/sda3 initrd=/boot/initramfs-linux.img systemd.restore_state=0 to the linux line.

Once again a huge thank you to everyone who helped me out.

KM6BXP


#12

Glad that you got it fixed @km6bxp , please mark it as solved, might help other members in the future.