[SOLVED] Issues with keyboard language (pt)


#1

Hi there,

So i’ve been running Archlabs for a while now, and thus far all of the problemas have found a fix, until i met this one.

Long story short, my keyboard is now in english layout instead of portuguese, but i still want the system language to be in en_us.

The only thing i’ve changed in regard to language in my system was adding english to the autocorrect feature in Chromium. Anyways, here’s some output of some commands that i ran on my system:

┌ ~
└> $ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev…
Trying to load rules file /usr/share/X11/xkb/rules/evdev…
Success.
Applied rules from evdev:
rules: evdev
model: pc105
layout: pt
Trying to build keymap using the following components:
keycodes: evdev+aliases(qwerty)
types: complete
compat: complete
symbols: pc+pt+inet(evdev)
geometry: pc(pc105)
xkb_keymap {
xkb_keycodes { include “evdev+aliases(qwerty)” };
xkb_types { include “complete” };
xkb_compat { include “complete” };
xkb_symbols { include “pc+pt+inet(evdev)” };
xkb_geometry { include “pc(pc105)” };
};

┌ /etc/X11/xorg.conf.d
└> $ cat 00-keyboard.conf

Use localectl(1) to instruct systemd-localed to update it.

Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “pt”
EndSection

┌ /etc
└> $ cat vconsole.conf
KEYMAP=pt
FONT=ter-i16n

As you can clearly see, all of the options that are assigned to keyboard layout clearly specify pt as the current layout language, which is what i want, so i’m unable to trace the source of this issue, and i’m unsure how does adding a language to Chromium for the autocorrect changes the default system keyboard layout language.

Thanks in advance.


Problems with rofi
#2

I think your /etc/vconsole should look like below.

KEYMAP=pt_PT.UTF-8

Actually after re-reading your post im not so sure. You want to be able to read the system/os in en_us but have the keyboard in pt Portuguese or should that be reversed ?


#3

I want to have the system in english (en_US) and have my keyboard in portuguese (pt), just like it was when i installed it. Since i didn’t change anything, besides the chromium auto-correct, and all the files seem fine to me, i’m wondering how the hell did this happen.


#4

Have you tried using localectl?


#5

Change the settings in

# for the Linux console
/etc/vconsole.conf

# for Xorg
/etc/X11/xorg.conf.d/00-keyboard.conf

# and possibly
/etc/default/keyboard

All localectl and setxkbdmap do is edit/create these files.

Refs. https://wiki.archlinux.org/index.php/Xorg/Keyboard_configuration
https://wiki.archlinux.org/index.php/Linux_console/Keyboard_configuration


#6

As i said, all of the options that resemble keyboard layout have the value ‘pt’, which is what i want, however, my keyboard is still in english. Here are the files that you told me to edit:

┌ /etc
└> $ cat vconsole.conf
KEYMAP=pt
FONT=ter-i16n

┌ /etc/X11/xorg.conf.d
└> $ cat 00-keyboard.conf

Use localectl(1) to instruct systemd-localed to update it.

Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “pt”
EndSection

┌ /etc/default
└> $ cat keyboard

KEYBOARD CONFIGURATION FILE

Consult the keyboard(5) manual page.

XKBMODEL=""
XKBLAYOUT=“pt”
XKBVARIANT=""
XKBOPTIONS=""
BACKSPACE=“guess”


#7

running localectl returns the following:

┌ /etc/default
└> $ localectl
System Locale: LANG=en_US.UTF-8
VC Keymap: pt
X11 Layout: pt

I clearly must be missing something here because all of the values, besides language, are ‘pt’ which is exactly what i want.


#8

Hmm yea that is odd. What wm/de are you using?

Perhaps the xfce4-settings-manager has a keyboard section? A lot of the time these desktop settings managers override the system setting listed before. I hate this personally as it’s not even easy to find during diagnosis of issues.


#9

I have i3-gaps, but, i’m not unsure what i did before, i do have some xfce settings on my computer. The one that says Keyboard is currently on ‘use system defaults’, and forcing a change to the portugues layout turned out to have no effect.


#11

I have the exact same problem.
A few days ago I had the system language as en_us and the keyboard as pt and everything worked.

It broke when I did a system update.

I suspect that this update broke the config.

[2019-02-04 21:21] [ALPM] upgraded xkeyboard-config (2.25-1 -> 2.26-1)

How can I revert or be sure that it was this update?


#12

So running

setxkbmap pt

Does the keyboard output the proper keys after?


#13

I had already tried that, got the following:

┌ ~
└> $ setxkbmap pt
Error loading new keyboard description


#14

You probably need to do this as root, it will also modify files (I think), still I thought it would prompt or something, maybe I’m wrong. Just to be sure though, your keys still register as the same, correct?


#15

https://bugs.archlinux.org/task/61634?project=1&string=xkeyboard-config

Patch included in the bug report.


#16

it appears that i’m not the only one, thanks a lot i’ll look into it, but i can only do it tonight, but based on the comments they managed to fix it using a patch.


#17

The patch worked, many thanks!
Also just for the future bugs that might occur, is it the official Arch bug forum?


#18

Marked this thread as solved, if somebody has the same issue, please check the link https://bugs.archlinux.org/task/61634?project=1&string=xkeyboard-config and download the patch created by user joao-O-santos.


#19

The bugs on that site are for the upstream Arch Linux distribution, yes, but they will also apply to ArchLabs (except for the ArchLabs-specific packages, of course).

However, please don’t post stuff there (or on the Arch forums) without first replicating the problem in pure Arch, thanks.


#20

Good call about Arch Forum postings @Head_on_a_Stick . It will/would save loads of hate on the op.