[SOLVED] Issue with cursor theme

Hi, so I installed capitaine cursors from here:

So, after applying the cursors, I logged out and logged in back for changes to take effect. One thing I noticed and which bugs me is new cursor theme only shows when I hover over the open applications but it shows default cursor if my cursor is on empty desktop or when I hover over polybar. What could be causing this? Is there anyway to show new cursor theme when cursor is on blank desktop on when hovered on polybar? I am on archlabs openbox. Here is my system info:

❯ neofetch
                   -`                    arch@archlabs 
                  .o+`                   ------------- 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: 80UD Lenovo ideapad 110-15ISK 
               `+oooooo:                 Kernel: 5.11.8-arch1-1 
               -+oooooo+:                Uptime: 1 hour, 19 mins 
             `/:-:++oooo+:               Packages: 787 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.8 
           `/++++++++++++++:             Resolution: 1366x768 
          `/+++ooooooooooooo/`           WM: Openbox 
         ./ooosssso++osssssso+`          WM Theme: ArchLabs-Dark 
        .oossssso-````/ossssss+`         Theme: Adwaita-dark [GTK2/3] 
       -osssssso.      :ssssssso.        Icons: ArchLabs-Dark [GTK2/3] 
      :osssssss/        osssso+++.       Terminal: terminator 
     /ossssssss/        +ssssooo/-       CPU: Intel i3-6006U (4) @ 2.000GHz 
   `/ossssso+/:-        -:/+osssso+-     GPU: Intel Skylake GT2 [HD Graphics 52 
  `+sso+:-`                 `.-/+oso:    Memory: 944MiB / 3802MiB 
 `++:.                           `-/+/
 .`                                 `/                           
                                                                 

Just tested. It’s working fine in my system. Here is what I did,

  1. download the theme from pling
  2. uncompress & move it to ~/.icons
  3. select capitaine curesors as default
  4. log out and log back in

I am using Fluxbox though.

I did the same thing but I went with system wide install by copying the icon folder to /usr/share/icons/ instead of ~/.icons/ and it only shows new cursor theme when hovered over applications and shows default old cursor when its on empty desktop and yes and i also re logged in.

I usually avoid system installation like this. Maybe a reboot? I know it sounds silly :grinning:

@Eon
Try to change your icon theme manually. So do i.

in .gtkrc-2.0
and in
.config/gtk-3.0/settings.ini

ok so I moved these icons from /usr/share/icons to ~/.local/share/icons since ~/.icons is just symlink to that, applied cursor icons from settings, rebooted the system but still same issue haha.

I did what you suggested too @subjunkie but still no effect. Not sure what else to do to fix this.

Hola,

Quizá debe editar manualmente,

$ micro .config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml

[...] 
<property name="CursorThemeName" type="string" value="ArchLabs-Dark"/>
[...]

PD:

$ pacman -Ss capitaine-cursors
community/capitaine-cursors 4-1
    An x-cursor theme inspired by macOS and based on KDE Breeze
1 Like

Did you change the cursor theme within the xfce settings manager → mouse/touchpad → cursor theme. This is usually the cause. userzero also had the right answer above by editing the file directly.

yeah, thats how I originally changed it but cursor theme didn’t apply everywhere even after a reboot.

Just double-check the following places to make sure the old theme isn’t still mentioned:

~/gtkrc-2.0
~/.config/gtk-3.0/settings.ini
~.Xresources

Other than that, run this script see what it outputs as the theme:

#!/usr/bin/env bash
#
# /usr/bin/setcursor

# config files
gtk2=$HOME/.gtkrc-2.0
gtk3=$HOME/.config/gtk-3.0/settings.ini
[[ -e $HOME/.extend.Xresources ]] && xr=$HOME/.extend.Xresources || xr=$HOME/.Xresources

# we'll have to override libxcursor's default
default=share/icons/default/index.theme
glob_default=/usr/$default
user_default=$HOME/.local/$default
[[ -e $glob_default ]] && [[ ! -e $user_default ]] && install -D $glob_default $user_default

# cursor-theme entries
cursor_gtk2=$(grep "cursor-theme-name" $gtk2 | cut -d'"' -f2)
cursor_gtk3=$(grep "cursor-theme-name" $gtk3 | cut -d'=' -f2)
cursor_xr=$(grep "Xcursor.theme" $xr | cut -d' ' -f2)

cursor=$1

# find config last modified
if [ -z $1 ]; then
	cursor=$cursor_gtk2; newest=$gtk2
	[[ $xr -nt $gtk2 ]] && [[ ! -z $cursor_xr ]] && cursor=$cursor_xr && newest=$xr
	[[ $gtk3 -nt $newest ]] && [[ ! -z $cursor_gtk3 ]] && cursor=$cursor_gtk3
fi

# set theme in all config files
echo "setting cursortheme \"$cursor\""
[[ "$cursor" != "$cursor_xr" ]] && \
	sed -i "s/Xcursor.theme:.*/Xcursor.theme: $cursor/" $xr &>/dev/null && \
	xrdb -merge -I$HOME ~/.Xresources
[[ "$cursor" != "$cursor_gtk2" ]] && \
	sed -i "s/cursor-theme-name=\".*\"/cursor-theme-name=\"$cursor\"/" $gtk2
[[ "$cursor" != "$cursor_gtk3" ]] && \
	sed -i "s/cursor-theme-name=.*/cursor-theme-name=$cursor/" $gtk3 &>/dev/null
[[ -e $user_default ]] && sed -i "s/Inherits=.*/Inherits=$cursor/" $user_default &>/dev/null

# and in the realms of the GNOMEs
[[ -f /usr/bin/gconftool-2 ]] && gconftool-2 --type string -s /desktop/gnome/peripherals/mouse/cursor $cursor
[[ -f /usr/bin/gsettings ]] && gsettings set org.gnome.desktop.interface cursor-theme $cursor

exit

OMG running that script and after rebooting my system applied the cursor theme everywhere properly now. I don’t understand the magic. :heart_eyes:

When I ran the script, it showed output:

setting cursortheme "capitaine-cursors"
1 Like

Good to hear.

P.S. we are using the same cursor theme :smiley:

1 Like