[solved] Install ArchLabs with auto-partitioning to /dev/sda, but have /home on /dev/sdb? 2x SSD drives

Hello,

I haven’t been using Arch for nearly 1.5 years~ today I installed AL for the first time. So far I tried AL (with openbox) – needless to say, I don’t ever want to go back on base arch anymore after this great experience!

Is there a way to just use automatic partitioning to have system files on /dev/sda - but separate the /home directory to /dev/sdb? - Without having to touch cfdisk. I’m a bit lost here!

My question is specific to the install script, any help navigating it to achieve this result would be highly appreciated :slight_smile: blessings…

1 Like

I think I solved it! The issue was that my 2nd ssd (/dev/sdb) still contained old windows bootloaders and files, it was not formatted into ext4! So I formatted that drive just for fun, probably this is how I should of approached it from the beginning.

The issue was that when I selected “mount partitions”, it automatically did this process for only /dev/sda (and auto placed /home here too). And it didn’t even prompt me with an option to mount /dev/sdb (since it wasn’t ext4 formatted).

!Make sure drives you want to use for mounting are already ext4 formatted. (Yelling at my future self :stuck_out_tongue:)

  1. Format the 2 SSD drives (/dev/sda and /dev/sdb) as ext4 with cfdisk
  2. Do auto partitioning on the main drive, /dev/sda in my case
  3. Mount the drives (/dev/sda will be mounted auto-properly), then another prompt appears and now you can mount /dev/sdb and tell the installer you want /home on it.

Edit: This is the end result I got

2 Likes

Glad that you fixed it yourself @Sorcerer . Rewarding !

Good idea to reformat drives

1 Like