[Solved] Install Archlabs as UEFI system?


#1

Hi,
I am struggling with installing Archlabs as UEFI system. I’ve tried out different approaches (using the automated partitioning, manual partitioning with different partition schemes). Non was successful. At the end the installer always installed a BIOS system. Where can I find information about how to make the archlabs-installer install an UEFI system?
Thanks,
mipi


#2

@mipimipi My Archlabs is an UEFI install. No problems right now. My steps: In BIOS (boot section) i select UEFI. Then in the installer i select automatic partitioning. The installer use/select automatically the gpt table and fat32 for /boot.


#3

Sounds like you’re using legacy boot (booting UEFI systems in BIOS mode), go into your bios and change that setting (it should be in the boot section) , then the system should be booting in UEFI mode. If such a setting doesn’t exist then your system does not support UEFI.


#4

@subjunkie, @natemaia: Thanks, that was it. My laptop was still in CSM mode.

I found out that UEFI boot is working with LUKS but not with LVM.


#5

You’ll need to provide more info regarding what went wrong, Myself and other testers haven’t had issues with LUKS and/or LVM in combination or alone.


#6

Sure, sorry. I did the following in the archlabs-installer:

(1) Installation without LVM:
a. “Edit partitions” -> “auto partition”
–> 2 partitions (1: EFI partition, 2: another partition)
b. “Mount and format partitions”
–> Installer asks: “Select your the partition for root”
–> I selected partition #2 and continued with the installation
–> Works as I expected.

(2) Installation with LVM
a. (same as above): “Edit partitions” -> “auto partition”
–> 2 partitions (1: EFI partition, 2: another partition)
b. “Logical volume management”
–> I selected partition #2 for lvm and create a volume group
[–> BTW: The installer seems to only except volume group names that start with a capital letter which I find strange"]
c. “Mount and format partitions”
–> Now, the installer asks: “Select the file system for partition #1”. Which is strange, since I expect - as in (1) - to be asked for the / partition). There was no possibility to select the partition for /.

Another thing that I observed:
If I execute “pacman -Syu” before I start the installer, then LUKS doesn’t work. When I do “LUKS encryption” in installer and select “basic encryption”, then the installer return with an error message because some kernel module seems to be missing (sorry, but I didn’t note which one).

If I start the installer directly (without executing “pacman -Syu” first), then everything works fine.

BTW: There are now many things mixed in this thread. I could also create separate threads or post issues.

  • mipi

#7

Thank you very much for the detailed breakdown, it makes it much easier for me to find them.

There’s definitely a few errors in the installer causing (most of) the above issues, I’ll get them fixed.

Re: Updating the live session, yes if you update the system and a kernel module is changed you will have to load it with modprobe <module_name>