[SOLVED] How to get the sound working on a fresh Archlabs install (29/10/2019 release)?

Hello all, I am a former user of Archlabs. I just installed Archlabs today on my personal laptop.

I was using Debian for the past 1 year and today I decided to remove Debian and put Archlabs instead.

The installation went fine. The only thing that is not working is my sound. Whenever I play any media files, there is no sound.

I installed alsa-utils and pulseaudio but it did not work. Please help. I would be grateful for any help.

Did you change from default pulseaudio to alsa?

If you’re using pulseaudio, open the pulseaudio volume control (pavucontrol in a terminal). You should be able to unmute and set your volume from there.

1 Like

Yes, that is what I did to solve my problem just now. :slight_smile:

Thanks a lot.

Well, I will just put what I did here so that it can be helpful to someone else when they face the same problem.

  1. Install the necessary packages first .

sudo pacman -S pulseaudio pulseaudio-alsa alsa-utils alsa-plugins alsa-lib alsa-firmware

  1. Not sure whether these packages are required or not, but I did install them just in case.

sudo pacman -S gstreamer gst-plugins-good gst-plugins-bad gst-plugins-base gst-plugins-ugly

  1. Then I went to the terminal and typed


We have to unmute everything and increase the volume. Press M for toggling mute/unmute. Use Up and Down arrow keys for increasing the volume.

  1. Also there is a volume icon at the top right. I use XFCE DE. Not sure about other DE though. It is volumeicon. Right click on it–>Preferences–>Change the hotkeys and enable it and change other settings you need. I enabled the hotkeys and the horizontal slider.

  2. There is this thing called as pavucontrol (Pulse Audio Volume Control). It is a GUI for pulseaudio. You can change the volume to the necessary level here too.

  3. Reboot.

It worked for me.

1 Like