[SOLVED] How can i install archlabs old-style (a.k.a. w/o customizations)

Hey guys! First of all, I would like to say thank you for your hard work on this project. I’m using archlabs more than a year on my notebook without any issues.

Recently i bought a new notebook for myself. I was planning about going with archlabs again but i couldn’t install it perfectly. I think installation phase has become more complicated for someone like me.
I’m looking for out of the box experience same as before. I mean that pre-installed programs, same terminal, same config files, same menus, same vm/dm (i don’t know which one is correct in here), even same right click menu and pre-configured color themes.

To sum up, how can i get an archlabs running notebook like former. I’m not an expert at gnu/linux, but I believe that if you help me I can achieve.

Thanks to every single person who reads my message.

Sincerely yours

Hi @ulpian and welcome to the forum. Did you by chance kept an old iso somewhere or have the usb installer that you used to install on your other notebook? Have you tried the newest iso? The installer on the newest iso has easy to follow instructions for an efi install. You just need three partitions (recommended). You need the boot partition, the root partition with ext4 journal (recommended), a home partition with ext4 journal. The swap can be a partition or a file.

1 Like

Hey @sevenday4 thank you. It’s nice to be here.

I have 4 iso files right now,
*4a1ce85fc8380ea8e0945b603aa8d66f538c42ac *archlabs-2018.07.28.iso (contains old installer)
*85b290cd4f8de4088b14ccbf89c11ec06834e10d *archlabs-2018.12.17.iso (might be faulty, sha1sum didn’t match with Sourceforge)
*55a057690fd28ef9a41ec98004ea8711e5cb484c *archlabs-2018.12.17.iso (fresh download)
*8cbcb1416e4389ec5e95ba232de7224215961bb8 *archlabs-2019.01.20.iso (fresh download)

At first, I tried going with lastest iso as normal, installation phase a bit complicated, but it’s fine. Here is my step-by-step installation log

-mount and partitioning > auto partitioning worked well (/dev/sda1 and /dev/sda2), root mounted on / with no ext4 mount options(?) (/dev/sda2)
-bootloader grub (dev/sda1)
-create user and set passwords - done
-configure system settings

  • 3 options for shell, i’m going with bash without any idea?
  • hostname - done
  • locale - done
  • time zone - done
  • kernel - vanilla arch
  • mirrorlist > reflector, Netherlands - done
  • select window manager or desktop (optional) > just selected openbox only here, should i select more of them?
  • login management > lightdm graphical login
  • select additional packages > didn’t select any of them
  • files downloads and installation is super fast. Finished, rebooted without USB pen drive. Grub screen, count down, boot, lightdm login, first encounter with desktop.

But there is no infographic sidebars, no file explorer, no programs, no colored and beautiful informative terminal etc…

And than i tried my chance with “archlabs-2018.07.28.iso” which is contains old installer and old system files of course. In installation there is a pop-up, which says “You really need to update!! 515 New packages”. I just ignored it and continued to installation.
Installation was a lot easier, almost completely did it with pressing “Enter”.

  • Al-Hello welcomes me, but it doesn’t work as expected.
  • Out-dated system is painful. Lets update system first.
  • A lot of replacing questions about system files. Such as “Replace ca-certificates-cacert with core/ca-certificates? [Y/n]” “Replace geoclue2 with extra/geoclue? [Y/n]”
  • I’m saying Y to everything
  • Now i’m getting some conflicts. “archlabs-polybar and archlabs-user-skel are in conflict. Remove archlabs-user-skel? [y/N]” Saying Y again.
  • Woah, 676.58MB download size update. Almost every file will be updated
  • Download took a few min
  • A lot of invalid or corrupted pgp signature. “Do you want to delete it? [Y/n]” y deleting
  • errors occurred, no packages were upgraded.
  • get into a vicious circle

Any help would be greatly appreciated.
Sincerely yours

1 Like

Maybe this can help with skel conflict:

This is where the two future installers will come in usefull, many novice users will like the ability to have a beginner or base install method as apposed to say an intermediate and experienced user who understands more complcated installation methods.

I get your point but I have to say, I feel like this is not really an installer issue as installation of the newest iso seems to work just fine. It rather seems that the OP is not happy with the config files.

@ulpian: Is your problem solved, yet? I would recommend against using an old ISO and work through all the pacman conflicts. Just go with the newest ISO which seems to install just fine, use zsh which is the “recommended” archlabs shell and go from there.
What do you mean by “sidebar”? I do not remember archlabs featuring a sidebar? But I might be wrong here.
Termite is the “standard” archlabs terminal and it should have a config file that makes it look like you described. However, if not, you can easily just download the config from the archlabs bitbucket.

1 Like

Hey all. Thank you for all helpful messages you wrote.
I don’t have enough time to solve my problem. But I realized where I made a mistake. I’m going to reinstall system asap.

  • select additional packages > didn’t select any of them

@xsme Thank you for these names (zsh, termite etc). BTW infographic sidebar was conky (I have just learned that name)

Sincerely yours

Glad it worked. However, please be aware that with time and updates (and you should regularly update if only for security reasons) your system might require some manual intervention now and then. You can always come here and ask but archlinux/-labs (and basically all rolling release distros) mostly require you to spend some time on it sooner or later.

That being said, best of luck to you :slight_smile: