[Solved]Do not start the polybar and do not work rofi

Hello!
A very long time did not update the system, after the update does not start the polybar and does not work rofi-apps.
At the old forum there was a solution for the rofi-apps, now I can not find a solution to this problem.
Please help me!
I am ready to give all the necessary information about the system

1 Like

I have installed yaourt polybar, he does not work too. (((

sudo ln -s /lib/libjsoncpp.so /lib/libjsoncpp.so.19

  • this action did not help

Hi @dikoobraz could you do this for me?

sudo pacman-Syyu 

And then see what happens and post what is the result. Thank you.

@dikoobraz polybar and archlabs-polybar are conflicting files. So, if you used yaourt install polybar, please ensure archlabs-polybar is not installed.

To restore polybar, a sim link will need to be created. You did attempt this, but the versioning was wrong, as libjsoncpp recently received a version bump again. So, you would need the following symlink to you make it work with nodejs:

sudo ln -s /usr/lib/libjsoncpp.so /usr/lib/libjsoncpp.so.20

Otherwise polybar and nodejs will not recognize the file, and without rebuilding polybar against nodejs, it will still be broken.

As for rofi, please post the output of:

locale -a

This behavior you describe, can happen when system locales have been dropped.

Here we go again? It seems we have stamp out these little fires every time they make changes to files without notifications to other distros. I found some apps that I used to be able to use until someone updated. Then I can’t use them anymore. :rage:

Thank you for participating!
I made a backup of the system, added the following packages to Ignore:

/etc/pacman.conf
IgnorePkg = arch-install-scripts archlabs-common archlabs-kickshaw archlabs-pipemenus archlabs-polybar archlabs-rofi archlabs-screenlock IgnorePkg=jsoncpp-1.8.4-2 nodejs-9.5.0-1

Updated the system again
Made following symlink:

sudo ln -s /lib/libjsoncpp.so /lib/libjsoncpp.so.19

Polybar and rofi are now working
Tell me what to do next, based on the above?
What packages to remove from the ignore?

Thank you for your responses

The “IgnorePkg” line in the pacman.conf should look like this:

IgnorePkg =

With a previous exception given for jsoncpp and nodejs, however this problem has since been addressed.

This is not against you, @dikoobraz, but running Arch or Arch derivatives, like our distro, requires some attention to good system hygiene, and I feel like this was something that you lacked. So, at this junction I am going to offer the following option, as a fix:

  1. Back up home directory, and install our most recent ISO.

Why do this? Because there no way for members to know the overall state of your system, without you providing the information requested.

I can not reinstall the system with a new ISO, so many settings are made, I do not want to lose them.
I did not update the packages only from the archlabs repository, because they constantly had problems. So I added them to ignore.

At the moment, I made a backup of a working system. I can clear the ignore list, update again, and give overall state of my system by your request.

If you help me, I’m ready to do it
Not so bad as it seems, reinstallation of the entire system is not needed
Will you help me AvnSgt ?

I’m afraid @dikoobraz you’re not understanding @AvnSgt request. Because you have not updated your system for sometime and cleaned up any orphaned or broken files, your system will degenerate and you will lose access to your data.
This is why I asked you earlier to update your system before I was going to help you with your main issues. Putting a bandaid on your problem is not going to work. You can also backup your .config file as well as as .bashrc and the rest of your home directory which will help you to rebuild your system more quickly. Also, save your skel file located in /etc/skel directory.

1 Like

Dear mister sevenday4. You mean, if I’ve missed some updates for some packages, do I need to reinstall the system completely ??? This is madness…

The system was updated regularly except for a few packages of archlabs
Everything works perfectly!! except polabar and rofi

Okay @dikoobraz have it your way. but you were warned!!

    sudo pacman -Syyu 
    sudo -Rns $(pacman -Qtdq)
    pacman -Sc

This will take care of your house cleaning. After you do this then we’ll see about polybar and rofi.

@dikoobraz
In your very first post:

You continue to later say here at the end:

So, I am confused, and you need to help me better understand what is going on. Because these two statements have very different meanings.

Using pastebin.com, please copy and paste, the output of the following commands:

cat /etc/pacman.conf
cat /var/log/pacman.log
sudo pacman -Qtdq

This is just a small bit to help me get started.

This is what they asked of me…

cat /etc/pacman.conf

cat /var/log/pacman.log

sudo pacman -Qtdq

Thanks for the help.
I really appreciate it

To begin with, complete the following steps:

sudo pacman -Rns $(pacman -Qtdq)  # This will remove orphans.

With favorite text editor. Open /etc/pacman.conf, as root.

Comment out both IgnorePkg lines, it is not necessary.
#IgnorePkg =   

Do not update the system,yet! This will cause breakage.
Run, the following two commands:

sudo pacman -Scc
sudo pacman -Syy

Now post the output of:

sudo pacman -Qe

to pastebin…
Do not update yet, we are still in a repairing phase.

1 Like

Yeah, I saw it @AvnSgt. Wow!

I did everything as you said…

sudo pacman -Qe

The final output I need is from:

sudo pacman -Qm

Post that so I can confirm that there are no conflicting packages left.

1 Like

Here it is

sudo pacman -Qm

Why would you not update everything?

1 Like

if I update everything, polybar and rofi do not work