ArchLabs Linux

[Solved] Clock setting is 6 hours ahead in XFCE

Hi all, need help with setting the clock inside XFCE. The time is correct at the GTK greeting page. But once I log into the XFCE desktop, the top bar right hand side where the time is displayed appears to be 6 hours ahead or something like GMT. I am on central time. Thanks.

p.s. I have Windows 10 on another SSD in this system. I suspect sometimes when I needs to boot into Windows, that system is messing up my clock on Arch Labs. Thanks.

Open a terminal and type

date

That will tell you your machine date time setting.

If you need to change any aspect of that here’s a way to do that without involving xfce GUIs:

https://www.garron.me/en/linux/set-time-date-timezone-ntp-linux-shell-gnome-command-line.html

Yes, that can happen because Windows default is to use local time and it resets the hardware clock. You haven’t changed Wondows 10 default have you?

If you dual boot read through this, ArchWiki hardware clock.

I also dual boot from separate drives. I have tried setting Windows to UTC with the registry fix (for Windows 7 though, not 10) and setting Linux to local time. Both worked.

@jsluk I face the same issue everytime. I dual-boot Windows 10 and Arch and everytime I login to Windows 10, the time is out of sync and out of my timezone. But time in Arch is always correct. For Windows 10, I manually change it everytime in the Settings and syncing the clock.

Anyway, I had faced same problem in Arch and I did this:

sudo timedatectl set-ntp true

You can check the status with

timedatectl status

For more info, refer Arch wiki here https://wiki.archlinux.org/index.php/Systemd-timesyncd

1 Like

Thank manyroads,
I typed date in the terminal as per your suggustion and it showed the correct date / time. However, the top bar where the date / time in xfce desktop still showed the incorrect time. Usually 6 hours ahead of my local time.

Thanks RatPack. I did not change anything in Windows 10 other than having to manually reset the clock because it goes to GMT time one I boot into Windows. I also have MX-19 on another ssd and I do not have to address or manually reset the clock. There are times after booting into Windows and then when I boot into MX-19, the clock would get messed up. However, MX usually self corrects the time in about 10-15 seconds after I log into the XFCE desktop.

Thanks Quantum_Sniper_007, I did this as per your instructions. Please see the output below. For some odd reason, XFCE desktop is displaying the UTC on on screen’s top menu bar!

Blockquote

$ sudo timedatectl set-ntp true
┌ ~
└> $ timedatectl status
Local time: Tue 2019-12-10 13:53:26 CST
Universal time: Tue 2019-12-10 19:53:26 UTC
RTC time: Tue 2019-12-10 13:53:26
Time zone: America/Chicago (CST, -0600)
System clock synchronized: yes
NTP service: active
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode cannot be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.

Blockquote

disable : RTC in local TZ: yes
and try this command

 sudo timedatectl set-local-rtc 0

or

#timedatectl set-local-rtc 0 

 #timedatectl set-ntp true 

or

 sudo timedatectl set-ntp true 

restart

Agree with @ector. RTC in local TZ: No is required. That’s what is causing the problem. Here’s the output of mine

$ timedatectl status
Local time: Wed 2019-12-11 21:59:59 IST
Universal time: Wed 2019-12-11 16:29:59 UTC
RTC time: Wed 2019-12-11 16:29:59
Time zone: Asia/Kolkata (IST, +0530)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

So, disabling RTC is required @jsluk.

Refer this: https://wiki.archlinux.org/index.php/System_time#Time_standard

Hope it helps :slight_smile:

Thanks @ector, Quantum_Sniper_007 and all,
I turned off RTC in local TZ per your instructions. Rebooted. Now the clock in XFCE panel starts counting at zero and resets to zero every time that I log into XFCE. Everything is still correct.

So I just deleted this clock in the panel. Re-installed another one and everything is fine. Clock is displaying the correct local time in the panel. I guess I can call this problem solved. Again, thanks and best regards.

1 Like