[Solved]Can't install archlabs(no connection)

Trying to install archlabs on my labtop. It says no connection. However I am able to ping before running installer the internet is working, but archlabs say no connection. Is there a way around this? any help would be great thanks!:wink:

If you have a connection then you should be fine to keep going with installer, ie you are able to ping before running the installer. But a little more info on the archlabs says “no connection” might help.

something like…

netstat -ie

can you ping both www.google.com AND 8.8.8.8? It might be a DNS issue.

enter nm-tui before you start the installer and connect, are you on wifi or ethernet?

It’s nmtui (no dash between) or nmtui-connect and the installer will open it if you aren’t connected…

The installer does the following to verify connection.

curl -sIN 'https://www.archlinux.org/' | sed 1q | grep 200

Note we don’t care about Google or other sites, if you can’t reach archlinux.org with a 200 OK response then you won’t be able to install.

1 Like

Ah yes apologies. I blame the head cold. Don’t sneeze and post.

thanks everyone for the help!
its working now

bit more info of what was happening.
I was able to ping all websites before running the installer. When I ran the installer it would check connection and kick me to nmtui to select my connection after selecting my connection Ethernet, it would say no connection no matter what including rebooting. I am using cloudflare for dns. Not really sure why but its working now.

So I ran nmtui before the installer then ran archlabs-installer and it works now thanks!:hugs:

2 Likes

I have a connection, but the line

curl -sIN ‘https://www.archlinux.org/’ | sed 1q | grep 200

Returns nothing, seems to be a certificate issue, as I run the same line on a working Archlabs PC and it returns: HTTP/2 200

So I am unable to get archlabs-installer working unless I go in and modify the script…

UPDATE: New PC BIOS did not have date and time set yet. Once set, all was good.

1 Like

I’ve never seen something like that before, how would that not be set?

Is that a new build @badmark !

1 Like

The time and date was set, but it was 5 months in the past!

1 Like

Haha! At least it was easy enough to correct.

2 Likes

I’ve dealt with time and HTTPS issues for years, why I didn’t immediately think it is beyond me!

Keep up the great work. Love this distro!

2 Likes

Well @badmark , sometimes stuff happens & when we think about it afterward we re surprsed as why we haven t taught about it then ! lol

2 Likes

Just had this issue, new computer thought it was 2005 some how. Anyways thank you for the post

1 Like

Hello,

Tried to install archlabs after wanting to have a leaner version of arch from manjaro.

Keep having this no connection problem during installation. Checked the BIOS date/time and tried running nmtui before the archlabs installer to no avail, Tried both wired and wireless connections, can ‘activate’ them, yet the same error message keeps popping afterwards. Hope to be able to try Archlabs out.

Can you

ping -c1 archlinux.org

If so you can edit /usr/bin/archlabs-installer around line 2497 replace the chk_connect() function with the following

chk_connect()
{
    msg "Network Connect" "\nVerifying network connection\n" 0
    ping -qc1 'archlinux.org' > /dev/null 2>&1
}

If not then you will need to troubleshoot your connection issues and go from there.

Thanks natemaia,

Used that ping command, packet transmitted, received, no loss for archlinux. Unfortunately, unfamiliar with command line syntax to edit the archlabs_installer (still a newbie with linux, even though used ubuntu/manjaro for some time now). Can you please point me to a tutorial on how to do such tasks? Distro hopping with this old laptop (it had manjaro/ bunsenlabs/ mabox/ etc.), it was the first time it had this warning.

1 Like

Ok then it’s likely ssl errors from curl.

An alternative to my above solution would be to enable the archlabs_unstable repository in /etc/pacman.conf by uncommenting the lines (remove leading #). Use something like vim or nano (cli text editors), there are manual pages man nano, help flags nano -h, and there’s lots of tutorials out there as well.

# /etc/pacman.conf
[archlabs_unstable]
Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

After that you should be able to run

pacman -Syy archlabs-installer

The latest installer version has the change listed above just has yet to move to stable.


First up I’d like to say that the installer issue shouldn’t happen, you shouldn’t be expected to edit the installer for a distro so my apologies but that doesn’t impact my next point. If doing things like editing text and running commands isn’t something you’re comfortable with I don’t think this is a great distro and you will likely have a bad time. Though we may have a (somewhat functional, somewhat easy) installer you’ll still be expected to be familiar with using and maintaining an arch system. Don’t let me dissuade you though, everyone starts somewhere and if you’re wanting/willing to learn then welcome aboard.

Cheers

1 Like