[SOLVED] Cannot install because usb keyboard is not detected


#1

Hi, I would appreciate some help because I really want to try this distro.
I am unable to use my keyboard at all
I tried connecting another keyboard and I also have tried connecting to every USB port.
I checked the BIOS and I don’t have fast boot/quick boot enabled or anything similar. The keyboard works well when I have to press F10 to get to the BOOT menu, but then in the live iso menu I cannot use it anymore.

Thanks in advance


#2

I’m curious - does your systems Bios allow for USB security? I’m not saying that could be the issue here, but that “feature” has bitten me a few times when I needed to enhance my wife’s All-In-One. But I assume that since you used the system before the AL install, it worked fine.

If your Bios does have that feature, you might want to review the current settings just to eliminate the easier and obvious causes.


#3

No, it doesn’t have that option. The keyboard work just fine with other distros live usb like mint, manjaro or arch. I really don’t know what could it be.


#4

Another issue could be whether you have USB 2.0, USB 3.0, or USB 3.1. I had issue when I had my keyboard hooked up to the USB 3.0 port. When I moved to the USB 2.0 port, there wasn’t any issue.


#5

Sorry - can’t be much more help beyond this. Soon tho, I’ll be moving away from lappies to desktops so I’ll watch this thread for reference.


#6

I would move your keyboard to another port. Sometimes, certain ports may be finigy when working in the tty mode or virtual mode.


#7

OP stated:

Although that would have been my first suggestion, too.


#8

Occam’s razor - There must be something about the keyboard that AL does not understand.
So - what type of USB keyboard is this? Anything out of the ordinary from any other standard USB keyB? Off brand? Drivers required? Additional features that might set it apart from any other?

Just trying to understand what makes this KB non-responsive in this situation.

EDIT: I re-read the original posting. Allow me to modify the above statements. What sets this system (USB ports) apart from other systems? Since you have tried other USB keyboards in the same system and none appear to work, does the same issue happen with USB mice attached to this same system when booting AL? If the USB mice produce the same results as the KB, then there is something about your hardware that AL does not see or understand.

AND, are you dual booting? Is Windows 10 installed. well - that kinda blows my line of thinking since you said other live distros work, so nix the idea that there is some secure boot thing going on.


#9

What type/brand computer you using?

I have a Toshiba laptop that has keyboard issues similar to this. I have to append:

i8042.nomux=1 i8042.reset

to the end of the grub boot command line; press “e” when the grub menu appears and add them before booting the live session. Need to repeat the process after installing then add it to the /etc/default/grub; update grub after that.

Don’t recall ever having to do that with an external keyboard though.


#10

@acquanero a little more info would be helpful.

Age of your hardware?

Wireless or wired peripherals?

What other distros have you tried and how long ago?

Off top of head…
I have struggled @ times with both wireless mouse and keyboard due to RF interference, @sevenday4’s advise is solid with that respect. So too is @PackRat’s.

Quite honestly, I’d pull in the iso again, preferably by torrent and verify it’s integrity to insure it’s not confogulated <-- (yep, my word and trademarked for evermore) :joy:


#11

Yep, I would suggest the output of this in terminal, might help.

inxi -Fxz


#12

Try pressing at boot time “e” and then add ‘noapic’ to the kernel line (at the end). Then press “b” to boot. Also,
what does your dmesg say? The more info we have, the better to understand the issue so that we can help you. Also, answers from @Glenn questions will also be helpful.


#13

System: Host: acquanero Kernel: 4.15.0-20-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: desktop Mobo: Intel model: DH67BL v: AAG10189-211 serial: N/A
BIOS: Intel v: BLH6710H.86A.0146.2011.1222.1415 date: 12/22/2011
CPU: Quad core Intel Core i7-2600 (-MT-MCP-)
arch: Sandy Bridge rev.7 cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27138
clock speeds: max: 3800 MHz 1: 1649 MHz 2: 1658 MHz 3: 1600 MHz
4: 1598 MHz 5: 1601 MHz 6: 1599 MHz 7: 1600 MHz 8: 1608 MHz
Graphics: Card: NVIDIA GF108 [GeForce GT 430] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nouveau (unloaded: modesetting,fbdev,vesa)
Resolution: 1920x1080@60.00hz
OpenGL: renderer: NVC1 version: 4.3 Mesa 18.0.5 Direct Render: Yes
Audio: Card-1 Intel 6 Series/C200 Series Family High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 NVIDIA GF108 High Def. Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network: Card: Intel 82579V Gigabit Network Connection
driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
IF: eno1 state: down mac:
Drives: HDD Total Size: 1000.2GB (2.8% used)
ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 369G used: 12G (4%) fs: ext4 dev: /dev/sda6
ID-2: swap-1 size: 16.00GB used: 0.00GB (0%)
fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 42.0C mobo: N/A gpu: 31.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 231 Uptime: 1 min Memory: 582.2/16010.1MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56


#15

I cannot press “e” or “b”. It just doesn’t work.


#16

That’s interesting. I have the same motherboard

This isn’t making sense. I would try @Glenn’s suggestion, and redownload the iso. I would suggest, if that is you have a spare one, using a different thumb drive.


#17

It’s really odd. As soon as I get home I would try redownloading the iso and using a diferent thumb drive. Thanks


#18

I don’t know about the usb mice because I cannot get further than the first menu after you choose to boot from the usb. I was trying to do a fresh install using all the hard drive for archlabs. I have dual boot with windows 10 and mint 19


#19

Finally!!

https://imgur.com/pBY3kUA

The Legacy mode was enabled. After changing to UEFI mode I was able to use the keyboard

beautiful distro BTW. Thank you for the help.


#20

Glad that it s finally resolved !


#21

Interesting, but if you change from legacy to UEFI, that may cause your other OS that you have installed on your machine to fail. That is if the are installed in legacy format.