[SOLVED] Archlabs repo invalid

#1

Hello! I’m trying to install updates for AL-2018.03, but I get:

:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
archlabs_repo is up to date
:: Starting full system upgrade…
error: could not open file /var/lib/pacman/sync/archlabs_repo.db: Unrecognized archive format
there is nothing to do

In my pacman.conf:

[archlabs_repo]
Server = https://bitbucket.org/archlabslinux/archlabs_repo/raw/master/$arch
Server = https://sourceforge.net/project/archlabs-repo/files/archlabs_repo/$arch

Help me please!!!

[UPD]

Thank you all very much! Solved a problem:

[archlabs_repo]
#Server = https://bitbucket.org/archlabslinux/archlabs_repo/raw/master/$arch
Server = https://downloads.sourceforge.net/project/archlabs-repo/archlabs_repo/$arch

0 Likes

#2

@fafubimixo

Cool, got it done yourself, you changed the repos to 64bits mate !

0 Likes

#4

@fafubimixo

Oh, I m on another laptop right now mate, don t have access to my AL install right now.

Edit: Added stuff.

0 Likes

Archlabs openbox config on archlinux install, is it possible?
#6

Here is mine

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# The multilib repositories are enabled by default in ArchLabs.
# If you don't run 32 bit applications you may comment them out

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# [archlabs_unstable]
# Server = https://bitbucket.org/archlabslinux/archlabs_unstable/raw/master/$arch

[archlabs_repo]
Server = https://bitbucket.org/archlabslinux/archlabs_repo/raw/master/$arch
Server = https://sourceforge.net/project/archlabs-repo/files/archlabs_repo/$arch

Let me know if you have any further issues, more than happy to help out.

Cheers

0 Likes

#7

If you wipe your cache with pacman -Scc then try updating again with pacman -Syyu

If you cannot access bitbucket then I suggest flipping or removing entirely the bitbucket severs from the list to avoid trying to use them, just comment out with a # hash like so

[archlabs_repo]
#Server = https://bitbucket.org/archlabslinux/archlabs_repo/raw/master/$arch
Server = https://sourceforge.net/project/archlabs-repo/files/archlabs_repo/$arch
1 Like

#11

Thanks, but doesn’t help : (

:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
archlabs_repo is up to date
:: Starting full system upgrade…
error: could not open file /var/lib/pacman/sync/archlabs_repo.db: Unrecognized archive format
there is nothing to do

Help me please!!!

0 Likes

#12

I would try this in terminal

sudo rm -R /var/lib/pacman/sync
sudo pacman -Syu

or: sudo pacman -Syyu

Lets see what it does.

1 Like

#13

Thank you all very much! Solved a problem : )

0 Likes

#14

@fafubimixo

That s great , what you ve done to fix it. Might help other members in the forum.

1 Like