[Solved] Another error on the installation

Hmm yea, it seems like there’s an issue in recent kernel versions (>=5.5) where the intel wireless driver is not working properly with these. This was apparently fixed so I’m not sure it’s related.

Can we see what module is loaded for it

lspci -k

iwlwifi, wl, I guess?
Wi-fi worked fine with 2019/10 ISO at the beginning, except there were constant errors from the kernel that were unbearable, I described it in the previous topic I gave a link to.

We can try some fixes from the wiki and see if it helps

modprobe -r iwlwifi wl  # disable and unload both modules

# re-load the iwlwifi module with some options to disable 802.11n band and enable encryption
modprobe iwlwifi 11n_disable=1 swcrypto=1

Well, the system says that the modules are already in use, and that’s probably because I am booting from CD, but we tried to apply the same options by usind e key in the boot menu, and that did nothing.
I wonder is there a way to connect to wifi not with wifi-menu? Because the laptop sees the router, so probably the bug is about the way of connecting?

Have you tried nmtui-connect?

If you apply them at boot use

iwlwifi.11n_disable=1 iwlwifi.swcrypto=1

I’m not actually sure if that will work but it should.

Try forcing the removal/insertion with modprobe using the force flag -f

EDIT: fixed cmdline options thanks @anon42040838

1 Like

From the gentoo wiki (arch also says the same)

No internet connection

If you can connect to an access point, but still can’t connect to any server or get any connection to the internet it might be worth a try to disable 802.11n and/or enable software encryption. You can pass the 11n_disable=1 or 11n_disable=8 and/or swcrypto=1 option to the iwlwifi module. In order to pass the option automatically on module load create the file /etc/modprobe.d/iwlwifi.conf as follows:

FILE /etc/modprobe.d/iwlwifi.conf Disabling 802.11n, enabling software crypto

options iwlwifi 11n_disable=1 swcrypto=1

https://wiki.gentoo.org/wiki/Iwlwifi#No_internet_connection

So, fortunately, nmtui-connect worked. I guess that’s the command archlabs-installer uses. It didn’t work on 2020/03 beta.
Applying iwlwifi options, on other hand, did nothing. I am not even sure they were applied, cus I just typed them at the end of the only line and hit enter, there was nothing else to do.

By the way. I’ve tried the newest vanilla arch from flesh drive, and it was connecting to wifi perfectly without any errors.

Can we mark this one as solved?

I’ve not finished the installation yet, just tried the connection. I will know for sure tomorrow.

1 Like

To apply module options from the kernel command line use this format:

iwlwifi.11n_disable=1 iwlwifi.swcrypto=1

https://wiki.archlinux.org/index.php/Kernel_module#Using_kernel_command_line

The OP already tried software encryption in their other thread but we didn’t try 11n_disable=1.

1 Like

Ahh thank you, that’s my mistake

1 Like

Indeed it is.

I suspect there will be some issues post install, no network manager etc. If you choose the “Copy ISO” option for the background install portion it should be fine.

And where do I choose it? I don’t fully understand, sorry.

After mounting is done, before returning to the main menu there will be a prompt for what kind of base install to use for the background portion while you do the rest of the setup and selections.

Update the installer before hand and you don’t need to worry about which option, I fixed the issues I could find with the new install method.

pacman -Syy archlabs-installer

Or I have a new build with it already installed if you prefer (same version, new file)

Were working on getting something out this week so apologies for needing to use gdrive links in the meantime.

2 Likes

Oh, it’s so neat. Thank you!

1 Like

The installation has worked, but now I cannot boot into ArchLabs. Only Windows appears.
Secure Boot is disabled, and I’ve tried to set all options besides Network-Boot above, still doesn’t work. Here is my boot status:


Also I made sure that the Archlabs exists on the hard drive:

Now looking for the solution.

UPD.: I’ve set systemd-boot as a boot loader, not GRUB.

Wooh, that was funny. My hardware always set windows boot loader as a default, and even efibootmgr did not help! I solved that problem from windows cmd by setting the systemd-bootx64.efi path for the windows boot loader.
Now I am on ArchLabs and it works great. At least the above problems are solved, thank you all, you are a great support team!

Glad that you got it to work in there @Rawicz .

Props to the ones that helped you out !

I have a laptop with a similar BIOS, you need to go back in.

First you need to set the “Supervisor” password in the Security tab (I know this is stupid but they disable some settings we need access to if you’re not)

Once set enable secure boot in the Boot tab.

Now reboot and re-enter the BIOS, in the Security tab there should be some more options for secure boot, we’re interested in the “Select an UEFI file as trusted”




After giving the bootloader a name you need to reboot and re-enter the BIOS one more time, now in the Boot tab there should be an entry like “EFI File Boot 0: THE_NAME_YOU_USED”.

Hope that helps.

2 Likes