Show Us Your Polybar

That’s really too bad. His Polybar configs match almost exactly what I have in mind in this period of time. I would have loved to receive some inputs from his config file.

1 Like

Here is his GitHub, you may find what you are looking for here

1 Like

Thank you very much for your help

1 Like

Hi, I’m new to this and very ignorant on the subject, how can I change my polybar? where?

The configs are in ~/.config/polybar.

The configs are broken in to three separate files master, modules and config.

1 Like

Dual screen setup, 2 bars here.
Monitor 1, modules: i3, weather, network-speed (with conky), mail.

Monitor 2, modules: pulseaudio, status of cmus & ncmpcpp, coreuse, cpu temp, nvidia gpu temp, memory, combined arch & aur updates, clock, date, logout

6 Likes

How to integrate conky and polybar?

hi @al0o0z, just create a module for example:

[module/networkspeed]
type = custom/script
label = %output%
exec = conky -c ~/.config/i3/conkyrc
tail = true
format = <label>
label-foreground = ${colors.blue}
click-left = nm-connection-editor &
format-padding = 1 

This one is my network-speed module with this conkyrc on my network interface enp56s0f3u3.

out_to_x no
out_to_console yes
update_interval 1

TEXT
down ${downspeed enp56s0f3u3}/${totaldown enp56s0f3u3} up ${upspeed enp56s0f3u3}/${totalup enp56s0f3u3}
5 Likes

@archus Thanks a lot. polybars buil in network speed module gives wrong info.
Thanks to you now i can use conky as netspeed monitor :slight_smile:

hello i a new to configuring polybar i am running the example polybar is there a way to change it to black?bc i change the backround color from 222 to 200 and its as black asmy tint2

A work in progress:

4 Likes

Nice Pack, looking really good.

Nice & clean @PackRat

@Dobbie03 @altman - thanks; finished it:

5 Likes

Looks great @PackRat

1 Like

Looks impressive. Love it.

@rml - workspaces module for my yaxwm polybar:

;;==========================
;;
;; workspaces
;;
;;==========================

[module/xdesktops]
type = internal/xworkspaces

; Only show workspaces defined on the same output as the bar
;
; Useful if you want to show monitor specific workspaces
; on different bars
;
; Default: false
pin-workspaces = false

; Create click handler used to focus desktop
; Default: true
enable-click = true

; Create scroll handlers used to cycle desktops
; Default: true
enable-scroll = false
reverse-scroll = false
fuzzy-match = true

; icon-[0-9]+ = <desktop-name>;<icon>
; NOTE: The desktop name needs to match the name configured by the WM
; You can get a list of the defined desktops using:
; $ xprop -root _NET_DESKTOP_NAMES
icon-0 = 1;
icon-1 = 2;
icon-2 = 3;
icon-3 = 4;
icon-4 = 5;
icon-5 = 6;
icon-6 = 7;
icon-7 = 8;
icon-8 = 9;
icon-9 = 10;
icon-default =

; Available tags:
;   <label-monitor>
;   <label-state> - gets replaced with <label-(active|urgent|occupied|empty)>
; Default: <label-state>
format = <label-state>

; Available tokens:
;   %name%
; Default: %name%
label-monitor = %name%

; Available tokens:
;   %name%
;   %icon%
;   %index%
; Default: %icon%  %name%
label-active = " %name% "
label-active-foreground = ${colors.foreground}
label-active-background = ${colors.darkgray}
;label-active-underline = 

; Available tokens:
;   %name%
;   %icon%
;   %index%
; Default: %icon%  %name%
label-occupied = " %name% "
label-occupied-foreground = ${colors.foreground}
label-occupied-background = ${colors.yellow}
;label-occupied-underline = #555555


; Available tokens:
;   %name%
;   %icon%
;   %index%
; Default: %icon%  %name%
label-urgent = " %name "
label-urgent-foreground = ${colors.foreground}
label-urgent-background = ${colors.urgent}
;label-urgent-underline = ${colors.urgent}

; Available tokens:
;   %name%
;   %icon%
;   %index%
; Default: %icon%  %name%
label-empty = " %name% "
label-empty-foreground = ${colors.dimgray}
label-empty-background = ${colors.background}

Never tried before, but it doesn’t work showing the occupied desktop.

3 Likes

Thanks! It actually looks like mine, I thought I was setting something wrong and couldnt see the occupied desktops. Thats not really a problem though, I’ll use it this way on yax

I checked some other window managers. Polybar was only showing occupied desktop for bspwm, so this appears to be a polybar issue, not yaxwm.

1 Like

yeah I just tried it on xmonad and qtile and the same thing happens. Must be a polybar problem indeed