Shotwell 0.32 not starting

I have searched for this and found nothing
Queue someone to show up my search incompetence, hopefully!

After updating (via yay) the community package for Shotwell (to 2:0.32.0-1), it no longer starts and if I try from a terminal I get the following:

leigh@T16-AL ~ % shotwell      
** Message: 13:39:53.215: main.vala:440: Starting session with system profile

(shotwell:3640): GLib-GIO-ERROR **: 13:39:53.240: Settings schema 'org.gnome.shotwell.plugins.enable-state' does not contain a key named 'org-gnome-shotwell-publishing-google-photos'
[1]    3640 trace trap (core dumped)  shotwell

Can anyone help me start to diagnose this please?
Anyone else with same / similar problem?

Cheers, as ever,

leigh@T16-AL ~ % neofetch
- leigh@T16-AL .o+ ------------
ooo/ OS: Arch Linux x86_64 +oooo: Host: 21BVCTO1WW ThinkPad T16 Gen 1
+oooooo: Kernel: 6.2.12-arch1-1 -+oooooo+: Uptime: 7 mins /:-:++oooo+: Packages: 1041 (pacman)
/++++/+++++++: Shell: zsh 5.9 /++++++++++++++: Resolution: 1920x1200
/+++ooooooooooooo/ WM: i3
./ooosssso++osssssso+ Theme: Adwaita-dark [GTK2/3] .oossssso-````/ossssss+ Icons: ArchLabs-Dark [GTK2/3]
-osssssso. :ssssssso. Terminal: xfce4-terminal
:osssssss/ osssso+++. Terminal Font: Monospace 12
/ossssssss/ +ssssooo/- CPU: 12th Gen Intel i7-1255U (12) @ 4.700GHz
/ossssso+/:- -:/+osssso+- GPU: Intel Alder Lake-UP3 GT2 [UHD Graphics] +sso+:- .-/+oso: Memory: 2503MiB / 15695MiB
++:. -/+/
. /

Search that entire GLib-GIO-ERROR message. Plenty of results a few are shotwell specific.


Thanks @PackRat
I did do that, honest Injun! (am I still allowed to say that?)

But I saw no Shotwell &/or Arch specific ones

Anyway, I did it again and sure enough, I just tried the first one I came across, even if it was for Ubuntu and Inkscape & it worked!

 rm .config/dconf/user

& reboot

I shall now slink off feeling silly …

In case you mess up the schema for any reason and you are no longer able to open the Gnome settings, e.g. gnome-control-center, just do the following and then logout and back in (or simply reboot):

rm .config/dconf/user

That’s it! Enjoy!

1 Like