SharpBang GNU/Linux

Live session is online, a bit different this time, but the Waldorf theme fits very well. A good blend of tools I see, nice. Hope to be able to play around with it in the weekend, unfortunately I have to work too. Anyway, really cool, and thank you!

1 Like

Hard @ work @Head_on_a_Stick . Thx

Azote v1.7.4 has just been released, and it seems to include all I wanted it to at the moment. Please package whenever you can. Further Azote development is going to take some time, so no release is expected very soon.

Burning iso right now, will install in a little bit.

v0.5.4 now out.


  • Removed geeqie (feh is enough)
  • Added 9base, suckless’ Plan9 port. The binaries are added to PATH and can be specified by prefixing 9 before the command (just like with the Arch package).
  • Tweaked the tint2 configuration. It now looks suspiciously like the Plasma panel, which is nice.
  • Corrected the menu entries for the terminal applications (htop, ranger & vim) so that they now run in uxterm instead of plain xterm.

And probably a few other things I can’t remember right now :slight_smile:

Moving forward, sha512sum generation & deployment is now automated along with the rest of the build system and I’ve added my own GPG key to Github and enabled automatic GPG signing for all commits.

The release will be any time now and the version will then be bumped to match Debian’s current stable point release, ie 10.1.whatever.


Nicee @Head_on_a_Stick , top work

1 Like

Wow, cool, downloading right now. Thank you! I hope to check the live session this morning before work. Gosh, am excited like a kid at Xmas.

Unfortunately it is snowing heavily, and somebody got to move it…

Edit; checked the weather forecast for this week, it will be warmer and rain…:grin:

One more edit, very smooth well functioning live session. Congratulations Head_on_a_Stick!


Ok, a good start of an ordinary weekday. Black coffee and an installation of 0.5.5 over the previous release. I am using an old T400 for this, got a ssd though, and that helps. Thanks for keeping the Waldorf theme, fits really nicely in. There are some changes to be done of course, but just small visual adjustments to my personal liking.

Looking forward to the SharpBang future development, I ´ve become a fanboi of it. :nerd_face:

Downloading. :grin:

Alive. :sunglasses:

Installed. :nerd_face:

On Win10 / Virtualbox I’m getting:

FATAL Could not read from the boot medium! System halted.

I tried re-downloading the iso, didn’t help. The 0.3.2 version booted normally here.

When I click on the “Icon Browser” entry in the menu under programming, nothing happens. Has it been removed?

@nwg: thanks for the report but SharpBang doesn’t support VirtualBox, sorry. Hyper-V is better anyway, perhaps try that?

@orionH: no, the icon browser should still be there and it works in 0.5.5:

I’m just downloading 0.6.0 to test that now.

The command to launch it from a terminal (to check for error messages) is


YAD is awesome :smiley:

Nice @Head_on_a_Stick . Yad s also used by BL right !

Had a hard time finding the repo, lower back hurts too much I guess, hard to walk ! lol

Edit: have a BL install that could be changed to SB, changing the repo to yours will make it !

The installed systems don’t actually have the repositories added because I wanted to make a pre-configured Debian system rather than a new distribution.

Updating the package from the repository wouldn’t actually change your user configuration anyway because APT won’t touch anything in $HOME, to update the configuration use this after updating the package:

sharp-user-setup --refresh

Thx for the comeback @Head_on_a_Stick . Appreciated

Don t feel like reinstalling right now.

Do you have the firmwarefor the network included on the newer iso !

Didn t have it on the one I tried, sorry I don t remember the version used.

All the images should include non-free firmware (it works for my Intel wireless) but the kernel is a bit old now so might not work with very new devices.

Ok, thx for the comeback @Head_on_a_Stick , maybe I did try to install it too quickly, never know.

Edit; Will give it another shot with a newer iso.

Here s the message I get after repo change on my install, disabled BL repo ;

chown: changing ownership of ‘/home/altman/Release.key’: Operation not permitted

Edit; not as root I must say.

Edit 2: doesn t work as root, wonder if it has anything to do with permissions.

Which command did you run to get that message?

It is possible to add the key for my repository but I really don’t recommend it. Stick with BL — it’s a fantastic system and the devs really know what they’re doing :slight_smile: