SDDM Messed Up - Black Screen/No Login

I messed up my sddm config file with some theme edits and now when I boot, the system stalls at a black screen.

I think I need to boot from the grub> command line so I can get in and restore the backup sddm config file. I have tried a few suggested instructions on the net but without success.

Which commands do I need? Thanks.

Can you get to tty using Ctrl + Alt + F2 or F3?

1 Like

No. Neither produces any output - the screen stays black. Blank actually. I can see that the display is functioning.

If you can’t even get to tty, then maybe you’ll need to repair the relevant config file from a chroot via LiveUSB boot.

2 Likes

Thank you. I received that same suggestion from a user on linuxquestions.org

I have a current Manjaro live USB so I will boot to that tomorrow and see if I can fix the mistake I made :slight_smile:

1 Like

Onya! I’m an ex MJ user & still keep a LiveUSB of it simply because its chroot tool is really convenient to use [better than straight Arch which without the MJ script needs me to actually remember what to mount then do it – eeek!]. Much easier for a numpty like me to use & get good outcomes with minimal effort. Good luck.

I didn’t use chroot in Manjaro. How do you do that? I did this:

I ran su -s to become root. I was not challenged for a password. Strange. I had discovered from this article that I would have to mount the hard drive in the Live USB environment in order to gain access:

https://docs.intuitivetechnology.com…-copy-a-backup

Following those instructions, I ran (as root):

mkdir /mnt/recover
mount /dev/sda2 /mnt/recover

Using ls -a command, I was able to see that I had access to all directories and files on the hard drive. The sddm config file is at /usr/lib/sddm/sddm.conf.d/default.config I tried to open that with sudo gedit but gedit would not do that. I then copied the default.config file from my Backups directory to the location listed above. I shutdown the Live USB and booted into Archlabs. Problem remains - blank screen where the login screen should be.

What have I overlooked?

Press e with the GRUB menu entry highlighted and add systemd.unit=multi-user.target to the end of the line that starts with linux then use <ctrl>+x (at the same time) to boot the modified entry. That will stop SDDM from starting and allow you to log in at the console (TTY) screen. From there you can check the systemd journal and the SDDM logs and try to fix things (although you could also check the logs from a live ISO image if you prefer a graphical environment).

To edit system files with gedit use the GVFS admin backend:

gedit admin:///full/path/to/file
5 Likes

That worked and made my day!! Thank you!!

I had made a backup copy of the sddm default.conf file so when I got to the console I copied that file to /usr/lib/sddm/sddm.conf.d/ which overwrote the original default.conf file I had incorrectly edited.

I rebooted and the default login screen came up, and in I went as normal. I’ll try to be more careful in the future :slight_smile: although at least I did remember to make a backup.

1 Like

Great that it got sorted @DrewBC , props to @Head_on_a_Stick .

1 Like

Glad you fixed it with the excellent help from @Head_on_a_Stick.

You now don’t immediately need this, but as you asked, & just fwiw fyi, here’s some reference info.

  1. https://wiki.manjaro.org/index.php/GRUB/Restore_the_GRUB_Bootloader#Use_mhwd-chroot
  2. https://archived.forum.manjaro.org/t/rebooted-system-during-system-update/107701/2
  3. https://archived.forum.manjaro.org/t/tutorial-how-to-magically-fix-most-computers-that-will-not-boot-after-a-manjaro-update/73125

The method i personally like is per #3 above, ie, manjaro-chroot -a when booted from the MJ LiveUSB.

1 Like

Thanks. I will try to avoid creating another situation where I have to use one of the methods :slight_smile:

Oh, well you’re no fun then! :stuck_out_tongue_winking_eye:

I hope what they is true about learning from mistakes because I certainly do make my share of them. There will be another occasion soon.

1 Like

Yep, they always come !