SDDM - Log in Screen Theme

Hello, mates.


I’m using the KDE Plasma 5.22 and I cannot change the Log in Screen Theme. I change other theme, write my password, click on Apply, but the theme keeps stuck on Breeze.


Anyone knows how solve that, please?

How are you trying to change the theme, manual editing or some gui tool?

Arch Wiki for SDDM has a section about themeing.

2 Likes

I haven’t used Plasma in ages, but I thought you could change the theme in the Settings Manager. You can even download themes from the KDE Store. I hate SDDM and Plasma, so there is that, and to me SDDM is worse when you add other WM’s alongside Plasma. Plasma is slick and easy, but it also really sucks ass at the same time. The only positive I see about KDE is that it’s forcing the team over at XFCE to get it’s shit together and move the ball forward. At least with XFCE, it’s not like Plasma is to a desktop like the old AOL desktop, where XFCE is modular, and Plasma is all contained.

1 Like

Hello, mates (@PackRat and @drummer)


and

Yes, I’m using the System Settings to install the themes. But I can’t change them. It is stuck on breeze theme.

And I already read the arch wiki, followed its instructions and nothing, unfortunately.
But that problem is only occuring on plasma 5.22, cuz I have Kubuntu installed in another machine, with Plasma 5.18, and there I can change the themes.

Might be a bug then. KDE/Plasma have forum you can check? Might be a work around.

1 Like

Tried to change the config file? If it doesn’t work, try to remove the kde/plasma dirs in ~/.config/

1 Like

I’d just shitcan SDDM for LightDM, but that’s just me.

I added a line as indicated on arch wiki, but it did not work either, so I removed it from the file.

I remember changing the Current setting per the wiki:

Current theme

Set the current theme through the Current value, e.g. Current=archlinux-simplyblack.

It was a bit of a hit and miss, but overall that worked. Like @drummer mentioned i switched to lightdm on Plasma; easier with a supported config tool.

1 Like

I did it. But my path was /etc/sddm.conf.d/theme.conf and the value was breeze. I changed for McMojave, restarted the pc et voilà.


Thank you, folks.

1 Like