Rofr.sh -l font issue

Hello all,

I must have messed something up with my font config resulting in what you can see in this screenshot of rofr.sh -l:

There must be some conflics between fonts?

I installed a lot of fonts and the issue appeared with:

  • ttf-google-fonts-git -> removed and worked ok
  • nerd-fonts-complete -> removed and worked ok
  • TeXlive fonts (vanilla install) -> I did a sudo fc-cache -fv /usr/local/texlive/2018/texmf-dist/fonts and a fc-cache -fv /usr/local/texlive/2018/texmf-dist/fonts but I can not manage to make rosf.sh work again.

Any ideas?

Thanks


Christophe

I believe you need at least one of the nerd fonts installed for the icons to show; it was working until you updated the font cache.

1 Like

You shouldn’t need the whole nerd-fonts-complete package, an icon patched font is baked right into the ISO so the only way to remove it is to manually delete.

On the note of TeX Live setup, see the wiki (font section in particular) for simple setup instructions.
https://wiki.archlinux.org/index.php/TeX_Live

I don’t see the packages or steps listed above shown on the wiki so I would assume they are unnecessary.
I also think that this is just something that occurred due to the TeX fonts not being available to fontconfig by default for a reason, do they work where the should (in TexLive)? If so they why try to make them available to the rest of the system through fontconfig?

I’m just gonna say this one point as well, iconic fonts are somewhat of a nightmare, they all use the private character area to keep the glyphs, multiple fonts use the same area and have overlap so one font may completely bork your entire private character area even though it doesnt even include icons (likely what happened here with the TeXLive fonts)


On the note of issues regarding rofi, you have a few solutions

  1. change the icons used in ~/bin/rofr.sh to ones that do work for the setup you want, use something like gucharmap.
  2. avoid icons entirely and simply remove them leaving only the text in ~/bin/rofr.sh
  3. remove the packages installed, remove any fontconfig caches you can find, then start fresh but avoid manually screwing with fontconfig. The below command should find all fontconfig caches on the system
sudo find / -wholename '*fontconfig/*.cache*' | grep -v '/var/'

Thanks. I think you are right:

So I chose option 2.

Thanks again and sorry for my late reply.

All the best.

1 Like