ArchLabs Linux

Rofi Config Issue

I have trouble setting up my rofi. The config option for columns shows 1, and there is padding. But those options don’t work?

Image:

Config:
! Rofi
rofi.fullscreen: true
rofi.width: 100
rofi.lines: 5
rofi.columns: 1
rofi.font: DejaVu Sans Mono 14
rofi.bw: 0
rofi.padding: 400
rofi.eh: 2
rofi.separator-style: none
rofi.hide-scrollbar: true
!rofi.location: 0
rofi.line-padding: 10
rofi.separator-style: dash
!rofi.fixed-num-lines: false
rofi.show-icons: true
rofi.kb-cancel: Escape,Alt+F1

! State: ´bg´, ´fg´, ´bgalt´, ´hlbg´, ´hlfg´
rofi.color-normal: #00282828, #ebdbb2, #00282828, #003c3836, #98971a
rofi.color-urgent: #00282828, #ebdbb2, #00282828, #003c3836, #98971a
rofi.color-active: #00282828, #ebdbb2, #00282828, #003c3836, #98971a
! ´background´, ´border´, ´separator´
rofi.color-window: #ee282828, #ee282828, #ee928374

Welcome to the forum.

Check ~/.config/rofi and see if there is a config file in there. If there is that will be overriding what .Xresources is doing. Delete it that config file for .Xresources to tell Rofi how to behave :smiley:

The config i showed is the file in ~/.config/rofi. I removed the rofi configs from .xresources. Part of the config is working such as the colors, but not the columns or padding.

If i remove the config file at ~/.config/rofi and transfer the configs to the .xresources file, the same problem still occurs.

Did you merge your resources after making the changes?

xrdb -merge ~/.Xresources
1 Like

Yes, and i know the config is working due to the fact that the separator style changes when i change it. But the number of columns and padding doesn’t affect anything.

Try mine and see if it works for you.

rofi.fullscreen: false
rofi.separator-style: dash
rofi.hide-scrollbar: true
rofi.padding: 100
! rofi.eh: 1
rofi.bw: 0
rofi.lines: 5
! rofi.line-margin: 15
rofi.line-padding: 10
!rofi.location: 4
rofi.font: SF Pro Display-Regular 8
! rofi.show-icons: true
! rofi.levenshtein-sort: true
! rofi.sidebar-mode: true
! rofi.auto-select: true
rofi.columns: 1

! Window		'background'	'border'	'separator'
rofi.color-window:	#A6101010,	#00000000,	#cdcdcd

! State			'bg',		'fg',		'altbg',	'hlbg',		'hlfg'
rofi.color-normal:	#00000000,	#a4a4a4,	#00000000,	#00000000,	#A56B5B
rofi.color-active:	#00000000,	#ffdfd6,	#00000000,	#00000000,	#ffdfd6
rofi.color-urgent:	#00000000,	#ffdfd6,	#00000000,	#00000000,	#ffdfd6

This is what i get.

This has got me stumped. Sorry.

Let me take a little look around Google.

@JavaCafe01 Just try something for me. I dumped my current config as a rasi theme. Can you add this to your /usr/share/rofi/themes. Call it something like test.rasi

/**
 * rofi -dump-theme output.
 * Rofi version: 1.5.4
 **/
* {
    red:                         rgba ( 220, 50, 47, 100 % );
    selected-active-foreground:  rgba ( 255, 223, 214, 100 % );
    lightfg:                     rgba ( 88, 104, 117, 100 % );
    separatorcolor:              rgba ( 205, 205, 205, 100 % );
    urgent-foreground:           rgba ( 255, 223, 214, 100 % );
    alternate-urgent-background: rgba ( 0, 0, 0, 0 % );
    lightbg:                     rgba ( 238, 232, 213, 100 % );
    spacing:                     2;
    border-color:                rgba ( 198, 198, 198, 100 % );
    normal-background:           rgba ( 0, 0, 0, 0 % );
    background-color:            rgba ( 0, 0, 0, 0 % );
    alternate-active-background: rgba ( 0, 0, 0, 0 % );
    active-foreground:           rgba ( 255, 223, 214, 100 % );
    blue:                        rgba ( 38, 139, 210, 100 % );
    urgent-background:           rgba ( 0, 0, 0, 0 % );
    alternate-normal-foreground: var(foreground);
    selected-active-background:  rgba ( 0, 0, 0, 0 % );
    background:                  rgba ( 20, 20, 20, 90 % );
    selected-normal-foreground:  rgba ( 165, 107, 91, 100 % );
    active-background:           rgba ( 0, 0, 0, 0 % );
    alternate-active-foreground: var(active-foreground);
    alternate-normal-background: rgba ( 0, 0, 0, 0 % );
    foreground:                  rgba ( 164, 164, 164, 100 % );
    selected-urgent-background:  rgba ( 0, 0, 0, 0 % );
    selected-urgent-foreground:  rgba ( 255, 223, 214, 100 % );
    normal-foreground:           var(foreground);
    alternate-urgent-foreground: var(urgent-foreground);
    selected-normal-background:  rgba ( 0, 0, 0, 0 % );
}
window {
    padding:          50;
    background-color: var(background);
    border:           0;
}
mainbox {
    padding: 0;
    border:  0;
}
message {
    padding:      10px ;
    border-color: var(separatorcolor);
    border:       2px dash 0px 0px ;
}
textbox {
    text-color: var(foreground);
}
listview {
    padding:      2px 0px 0px ;
    scrollbar:    false;
    border-color: var(separatorcolor);
    spacing:      2px ;
    fixed-height: 0;
    border:       2px dash 0px 0px ;
}
element {
    padding: 10px ;
    border:  0;
}
element normal.normal {
    background-color: var(normal-background);
    text-color:       var(normal-foreground);
}
element normal.urgent {
    background-color: var(urgent-background);
    text-color:       var(urgent-foreground);
}
element normal.active {
    background-color: var(active-background);
    text-color:       var(active-foreground);
}
element selected.normal {
    background-color: var(selected-normal-background);
    text-color:       var(selected-normal-foreground);
}
element selected.urgent {
    background-color: var(selected-urgent-background);
    text-color:       var(selected-urgent-foreground);
}
element selected.active {
    background-color: var(selected-active-background);
    text-color:       var(selected-active-foreground);
}
element alternate.normal {
    background-color: var(alternate-normal-background);
    text-color:       var(alternate-normal-foreground);
}
element alternate.urgent {
    background-color: var(alternate-urgent-background);
    text-color:       var(alternate-urgent-foreground);
}
element alternate.active {
    background-color: var(alternate-active-background);
    text-color:       var(alternate-active-foreground);
}
scrollbar {
    width:        4px ;
    padding:      0;
    handle-width: 8px ;
    border:       0;
    handle-color: var(normal-foreground);
}
mode-switcher {
    border-color: var(separatorcolor);
    border:       2px dash 0px 0px ;
}
button {
    spacing:    0;
    text-color: var(normal-foreground);
}
button selected {
    background-color: var(selected-normal-background);
    text-color:       var(selected-normal-foreground);
}
inputbar {
    padding:    10px ;
    spacing:    0px ;
    text-color: var(normal-foreground);
    children:   [ prompt,textbox-prompt-colon,entry,overlay,case-indicator ];
}
case-indicator {
    spacing:    0;
    text-color: var(normal-foreground);
}
entry {
    spacing:    0;
    text-color: var(normal-foreground);
}
prompt {
    spacing:    0;
    text-color: var(normal-foreground);
}
textbox-prompt-colon {
    margin:     0px 0.3000em 0.0000em 0.0000em ;
    expand:     false;
    str:        ":";
    text-color: inherit;
}
error-message {
    background-color: rgba ( 0, 0, 0, 0 % );
    text-color:       var(normal-foreground);
}

Open the rofi-theme-selector and select it and tell me how it looks.

Also running rofi --help in a terminal shows under Global Options where Rofi is pulling the configs from for that function. Or at least if you have changed it from default.

here is what it looks like after using your rasi theme… i made sure to remove every other config that wasn’t a rasi.

Sweet, now can you run rofi --help in a terminal and post the output here please. I just want to check something.

If you wanted to you could just edit that .rasi file?

Just had a thought, @JavaCafe01 JavaCafe01are you using rofr.sh to launch rofi?

If you are try this instead rofi -show drun 'Run'

Looking at the rofr.sh script I am pretty sure you are, the relevant info:

  rofi -location 1 -yoffset 40 -xoffset 63 \
                -modi run,drun -show drun -line-padding 50 \
                -columns 2 -padding 50 -hide-scrollbar \
                -show-icons -drun-icon-theme "Oranchelo"
1 Like

Ah yes you’re probably right. I’m not at my workstation currently, I’ll check once I get back. I’m using the rofi script that came preinstalled with archlabs i3 edition…

1 Like

Yeah I just tested it. Definitely that.

Hello @JavaCafe01, welcome to the forum.