Redshift problem anyone?

Hi! I’m using the latest release (2018/06) and i can’t use redshift.
If i run it from terminal i get an error saying it has no permission to access geoclue2 (something like GDBus.Error:org.freedesktop.DBus.Error.AccessDenied). So it basically it can’t get a location.
When i run polybar module i get an error saying line 68 of toggle.sh has an error.

Does anyone have the same problem?

Not sure if your using the latest version or what but over here I get a full output that lists what is needed to get it working

Trying location provider `geoclue2'...
Using provider `geoclue2'.
Using method `randr'.
Waiting for initial location to become available...
Unable to start GeoClue client: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: 'redshift' disallowed, no agent for UID 1000.
Access to the current location was denied by GeoClue!
Make sure that location services are enabled and that Redshift is permitted
to use location services. See https://github.com/jonls/redshift#faq for more
information.
Unable to get location from provider.

So basically see https://github.com/jonls/redshift#faq

Cheers

I really didn’t want to use manual latitude and longitude, but i searching Arch forums i’ve noticed it’s a geoclue2 problem.
I managed a workaround, but it’s really not the perfect solution.
I found that if i have the following my bspwmrc it works:
/usr/lib/geoclue-2.0/demos/agent &

This way geoclue agent starts and redshift works.

Thank you guys for your support.

1 Like

I found a solution to this one.

edit your /etc/geoclue/geoclue.conf
add this at the bottom.

[redshift]
allowed=true
system=false
users=

It should work for now on with geoclue

If maybe we can add it to the default config in AL…or show me where and how and I don’t mind doing it myself. I need to learn these things.