Receive a git clone

I’d like to install this Git script … GitHub - ShoelaceMan/MagickShot: Bash scripted screenshot manager

After a git clone, just wondering how to make a config & run the script … or is that automatic in the git clone command?

Click on the “View Code” link to see the files. Looks like there is one bash script, an example config, and a Readme file. The Readme file has the installation instructions.

Looks like all you have to do is copy the script to a folder in your $PATH and make sure it’s executable. Follow the instrctions in the Readme to see where the config file needs to go. Copy the example config to that location and rename it according to the instructions.

You’ll need ImageMagick, slop, ffmpeg, and dzen2 installed for the script to work correctly.

2 Likes

“git clone” just clones the repository to your local build environment so you can work on it. It’s recommended that you create a “build” directory that you’ll have rwx access to and clone repositories into that. Otherwise, if you do this a lot, you’ll have git repositories cluttering up your home directory.

After cloning the git repo, there are usually instructions to build (if necessary) and install the software. Usually a Readme and/or Install file.

3 Likes
1. copy "MagickShot" to a place in your $PATH, for example, ~/.local/bin or /usr/bin, make it "755"
2. copy "exampleconfig" to "~/.MagickShot/config"
3 Likes

Thank you @PackRat & @chroot . First time I’ve done a git clone … most appreciate it!

:grinning:

GM

Your gonna love the heck out of git.

1 Like

Installation instructions

Simply clone the repo, make a config file, and run the script! The config file location is ‘~/.MagickShot/config’, and it should run out-of-box with default settings with the example config (once you create the save path in the example config)!

  1. Installed all the dependencies.
  2. Cloned the repo
  3. Make a config file … I assume that means setting local screenshot save path in ~/.MagickShot/config.
  4. Chmod 755 /home/******/build/MagickShot
  5. Reboot

Unfortunately, doesn’t work. Thinking I’ve done something wrong in #3.

That’s the config file. Check MagicShot.

confdir=~/.MagickShot

Report any issues to the project’s GH page.

1 Like

That’s the wrong path to the script. That command changed the permissions of the directory. After you clone the git repo to /home/username/build you should have /home/username/build/MagickShot.

chmod +x /home/username/build/MagickShot/MagickShot

then copy that MagickShot script to ~/bin or /usr/local/bin so it’s on your $PATH

Somewhere in that config file is the output directory specification. That directory will need to exist. I think it’s this section:

# Save Location
keepcopy=yes
filename=$(date +"%m_%d_%Y_%T")
imagepath="Documents/Pictures/Screenshots/$NAME"
videopath="Documents/Videos/Screenrecord/$NAME"
outfile="/tmp/MagickShot" #Uploader output file

That imagepath and videopath need to exist. So you need a ~/Documents/Pictures/Screenshots and ~/Documents/Videos/Screenrecord directory.

Run the script in a terminal and post any error messages.

Did the script dump some screenshots directly to your home directory? Sometimes that happens if the output directory does not exist.

2 Likes

Also need to create that ~/.MagickShot directory (note that it’s a hidden directory) and copy that example config from the git repo. Remember to rename it to “config”.

2 Likes

Yes, this is complete.

Yes, the script only was saved to ~/bin.

Yes, imagepath & videopath were both changed to my path.

Yes, I’ve created the ~/.MagickShot directory as a hidden, copied & renamed the config to "config.

I’ve ran the script in a terminal resulting in no errors …

[###@### ~]$ /home/###/bin/MagickShot
Loading config!
Usage: MagickShot []
-o Save screenshot in
-u Upload the file using specified uploader
-t Hide thumbnail
-s Specify region using slop (Must be used with -i or -v)
-r Take a recording
-i Take a screenshot
-d Use entire display server as region
-h Display this help dialogue
-v Display version info

When attempting to take a screenshot, the result is …

[###@### ~]$ MagickShot -i
bash: MagickShot: command not found

I’m probably wrong in attempting to run a screenshot from that last terminal command.

1 Like

What is the output of:

echo $PATH

2 Likes

/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

2 Likes

So it’s still not in your path. What shell are you using?

2 Likes

Using bash.

Put this in your ~/.bash_profile:

export PATH=$PATH:$HOME/bin

2 Likes

You’ll need to logout then back in.

1 Like

If you have auto login enabled in some form you’ll need to put that export snippet above it. In your bash_profile so it gets parsed and not left out.

1 Like

Yes, I’ve added to ~/.bash_profile.

export PATH=$PATH:$HOME/bin

Also yes, logged out & back in again. Autologin is enabled.

Nadda has changed.

What’s echo $PATH say now?