Ranger rc.conf

Hello everyone,

I’ve accidentally deleted the default rc.conf while I was customising ranger. I would now like to get the default ranger config back. The problem is, that I can’t seem to find it in the official GitHub and GitLab repos.
On the other side the search button on BitBucket is missing for me, so I don’t know where I should look for the rc.conf.

I have installed the i3 flavour of ArchLabs with the latest 2018.07 ISO.

Thanks in advance,
habanzu

We moved to Bitbucket a while ago. Get the configs here

https://bitbucket.org/archlabslinux/skel/src/master/home/.config/ranger/

1 Like

Thank you very much :slight_smile:

1 Like

No need to append [SOLVED] just ticking the post that solves your issue is enough :smiley:

@habanzu Before I alter any config, I always create a new directory (folder) named original and keep a copy of the unaltered config there. It’s saved me several times :slight_smile:

3 Likes

Best Linux advice you can follow!

2 Likes

lol, easier said than done with us old farts that we are.

1 Like

The same! I don’t know how many times I kicked myself in the arse when something goes wrong and I don’t have a backup for the original config file. I usually save it to my thumb drive as well in case of a complete disaster. You can also add .bak at the end of the name of the file.

Any user config present on the system will be stored in /etc/skel which is copied to the user’s home when created.

2 Likes

Hi guys,
I was thinking of making a new thread, but I might as well ask here.

I am trying to make a custom colour theme for Ranger, but am struggling to find an example anywhere?
Can anyone point me in the right direction, please?

Thanks,
Fatboy

Would it be this? -> colorschemes

There is another one here -> Elegant-Touch

And more -> specific colors for ranger

3 Likes

Yes! Exactly what I was looking for! Thank You so much @m.rogers!

2 Likes

You’re welcome!

1 Like

@anon39737049, if ever wanting to make a custom color scheme, I find this site really helpful and specifically this page, if wanting successive shades of a particular color. :slight_smile:

1 Like

Thanks brother. I will check it out. Loving Ranger these days. Just wish I can get it installed on my work laptop that runs an OS I shall not mention haha

Have you tried pip install ranger?

Does pip work in Windows?