Quick screen question

Yes now I have a question again.
In my latest install of Archlabs (macbookpro 13 retina) I use Lightdm . It took some time finding a solution for screen resolution in Openbox (I made a simple homebrewed script) but now I am starting to get irritated over Lightdm. How do I (pre) set screen resolution for Lightdm? Looked through Arch wiki but …

womp

1 Like

Well to be clear, in Lightdm everything is very small so it’s hard so see. Maybe I have to specify this in xorg? I will look up on how to do that.

womp

1 Like

@womp Just so you know, I have read your post but can’t understand what could be causing that. It’s been a little while since I’ve used a display manager so, wish I could offer better support.

1 Like

Is your pixel settings at 94 or 96?

With an Xorg configuration file:

https://wiki.archlinux.org/index.php/HiDPI#X_Server

EDIT: once that is set then you can remove whatever method you are using to correct the DPI at the desktop.

1 Like

Hi and thanks for interest!
Your link and solution should work but after following to the letter with “1680x1050_60.00” “i915” my system hangs on boot with no message just after “/dev/sdb2 clean…”
I did chroot a few times to edit but gave up and deleted so now I back to where I started.

womp

You already have the mode you want so you only need to set the screen dimensions and mode.

I

I thought I just did that!
/etc/X11/xorg.conf.d/10-monitor.conf

Section “Monitor”
Identifier “Monitor0”
EndSection

Section “Device”
Identifier “Device0”
Driver “vesa” #Choose the driver used for this monitor
EndSection

Section “Screen”
Identifier “Screen0” #Collapse Monitor and Device section to Screen section
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24 #Choose the depth (16||24)
SubSection “Display”
Depth 24
Modes “1680x1050_60.00” #Choose the resolution
EndSubSection
EndSection

This config hangs the boot process. I find it strange. It should work.

womp

Why have you attempted to force the VESA driver?

Is your output actually called “Monitor0” (check with xrandr)?

What does the Xorg log for the failed session say?

Try keeping the configuration as minimal as possible, just the Screen section (with the Identifier alone, if that works) and the Display subsection (with just the Mode) and see if that works.

I did throw away my config so I did a rewrite and forgot about the driver there. Anyway, xorg log shows an error “Parse error on line 1 of section InputClass”. Now I am a big fat question mark!

womp

You should post the entire Xorg log (via a pastebin if it is large) and also the entire Xorg configuration file that you are using.

You shouldn’t have any InputClass lines, you only need lines relating directly to the mode — Xorg will figure everything else out for itself.

Yes and thank you so much for your time!
Here is my xorg log https://gist.github.com/e9c33c6e846f2249e3d19485f2fde2ee

I do not have ONE xorg config file. I have 6! small ones.
keybaort : https://gist.github.com/88da8496d378db5d94effdf7aa7784ed
pointer : https://gist.github.com/c65302d2e8f30c9dfc7aded1a1bf9525
touchpad : https://gist.github.com/186443500b3a82eb0073c1466adfa16f
acc : https://gist.github.com/f4ec1daf272021adb2634d32ea57b87b
xpra-virtual : https://gist.github.com/5d98455995d90f8be6477e6f1fe4c27e
killx : https://gist.github.com/ec9a7fac3a8d813d3d3b3f05280063ce

womp

Should just need to set one file /etc/X11/xorg.conf.d/10-monitor.conf containing only the Screen section

Section "Screen"
    Identifier             "Screen0"
    Device                 "Device0"
    Monitor                "Monitor0"
    DefaultDepth           24
    SubSection             "Display"
        Depth              24
        Modes              "1680x1050_60.00"
    EndSubSection
EndSection

After some testing of the 10-monitor.conf I am puzzled. It has absolutely no effect on screen resolution in lightdm! Maybe I have to change someting in lightdm.conf?

womp

Does the configuration file change the resolution on the desktop itself?

I did a quick search and found this:

The interweb is full of answers :slight_smile:

1 Like

GREAT! That worked! Thank you very very much for your help!

womp

i am having the same problem but i am not using dual monitors with a vga,lightdm pops up blury as openbox deault resolution is 1920x1080,i fixed that problem by editing .profile any help?

I used arandr to set resolution and saved it as a script. Then use that script in autostart.
If you havent you could try that.

Womp

yes but i opened display and saved it that way, in arandr i saved the layout and i put
sleep 3 /home/.screenlayout/nameoflayout.sh in .profile but it didnt work for some reason am i missing something? maybe the ~/. in the begining i dont know i have also tried xrandr --output VGA1 --mode 1532x834 and dint work

You are not using Openbox?

Womp