Problems with lib32-llvm-libs (and by extent lib32-amdvlk etc.) and a 6800xt

I recently got a 6800xt from eBay as prices in Germany are calming down, and now have a Problem:
I previously used Manjaro-i3 and after plugging the card in and selecting proper drivers ran into Manjaro getting stuck on the graphical console and showing [drm:retrieve_link_cap [amdgpu]] *ERROR* retrieve_link_cap: Read dpcd data failed..
I was still able to get into a tty and start lightdm from there(previously failed 5 times during the same boot) but it got annoying and i couldn’t run tuxclocker or read fan speeds any more.
After a while i decided to try other distros and under mint i was able to use the drivers that AMD host for this model and get everything working properly (though with other problems related to i3)

Finally i decided to try archlabs as a last resort today and initially got everything working - only after installing steam i got the same error again and after narrowing it down i noticed it was triggered by installing lib32-amdvlk as a dependency. All other packages that include 32-bit vulkan drivers seem to have the same problem and in the end i narrowed it down (at least i think so) to lib32-llvm-libs.

Really hope you guys know what might be happening here as this is pretty much my last resort outside of turning to nvidia (which i don’t have the money for).

Hoping for responses, Hardware-Probe and system journal will be attached after i replicate a clean run with the error.

Steps to reproduce:

  1. have a 6800xt (maybe other cards as well, maybe it’s just me - not big enough of a sample size to tell yet)
  2. do a fresh install of Archlabs with i3-gaps (possibly other WMs - haven’t tried)
  3. sudo pacman -S steam
  4. reboot
  5. have lightdm crash

hw-probe:

journalctl:

Correction: installing lib32-llvm-libs does not seem to cause the problem, though previously uninstalling it solved it.

You have lightdm log files?

BTW, do you have to use lightdm?

Mainly using lightdm because manjaro-i3 used it and it also came preinstalled with the i3-installation for archlabs - currently off my pc for sleep but will be able to send a log file tomorrow morning gmt+2 - would be nice if you could point me towards where to look :slight_smile:

Also include xorg logs.

hope this is everything :slight_smile:

Update: after provoking the error yesterday i can’t seem to get rid of it anymore by going after 32-bit libraries of the amd drivers

https://wiki.archlinux.org/title/AMDGPU#Enable_Southern_Islands_(SI)and_Sea_Islands(CIK)_support?

1 Like

Followed that and it now boots properly - thanks :slight_smile:
Another quick question: do you know how i can run a script when lightdm starts? I did the same as when i was running manjaro (uncommenting the start script line in /etc/lightdm/lightdm.conf) but as you can see in the log lightdm seems to complain about that option - i run a 5120x1440@240hz capaple monitor and it defaults to the highest resolution, which my graphics card isn’t able to output due to known problems with the driver, so i need to run xrandr --output DisplayPort-1 --mode 5120x1440 --rate 120 whenever i get to the greeter to be able to see anything on my screen :slight_smile:

Glad it works now. Can you mark it “resolved” so that other people can use as a reference?

1 Like

Good call @chroot

Think i did now (new to the forum) - if so thanks for the quick help :smiley:

2 Likes