ArchLabs Linux

Problem with installation up on virtualbox

problem with auto-partitioning of the disk:


cfdisk also has an error.
help me please

Apologies there was an error with auto partitioning that is fixed with the latest version, to update the installer run:

pacman -Syy archlabs-installer

Then run the installer again and you should be good to go.

Thanks. This problem has been resolved.

Now, at the stage of mounting disks, an error occurs - it is impossible to mount sda2 in / mnt.

If possible could you post a screenshot or the text output from the error dialog.

a dialog with an error appears for a second and disappears. further returns to the main menu. too fast to take a screenshot.

Almost all error messages we display require you to accept to continue, otherwise they’re just information messages. One exception being mount failure, if you get this then please try to mount the partition yourself outside the installer and post the error

mount /dev/sda2 /mnt

Does the cursor advance to the next step after it returns to the main menu?

These messages you’re seeing are likely just info regarding the install mount process, when you use the auto partition feature and no luks/lvm the installer will auto select and mount all the partitions it created and just give quick info for each. Once the basic partitions are done, if there are no more it informs the user and returns to the main menu and the cursor is advanced to the next step. If an error occurs the cursor will either stay in the same place or jump back to the step required to continue.

You can also use the show device tree option (the first one) to check if the partitions did get mounted after being returned to the main menu.

You can also at any point Ctrl-z out of the installer and use the shell then when finished running commands use fg to resume the installer.

I encountered exactly the mount error. The next step was not available.

But at the same time I previously used luks encryption.

Today I tried to repeat all the steps. To show the output of the manual mount command, but everything suddenly worked on its own.