Printertrouble

Owning 2 Printers in my castle,

     one build by Mr. Samsung, HL-L2360D Monocrome Laserprinter

an other build by Mr. Epson, ET-2710 Color Ink Printer,

On my Wifes Asus Zenbook, running Bils win 11, both prints fine, also on my Thinkpad X220, running Marks Xubuntu (debian- based?), prints both.

My 7700k self build Desktop machine, running Archlabs ( Archlinux- based) say:

there is no avalaible Printer in your little home…

whats to do, to trouble shoot this,

or hint me, which supi dupi printer hell machine i shut by, not eating all my money…

cu, temporary not printing, stephan

Have you tried this yet, shows updated at the end of June/22.

https://aur.archlinux.org/packages/epson-inkjet-printer-escpr

2 Likes

ArchLabs doesn’t install printing support by default, you will need to install cups and enable the service as well as the driver packages for your printers.

3 Likes

Cups Printer management http://localhost:631/ says: no printers

ergo, sammiev, have tried…

@PackRat already done, but no printers…

cu, stephan

Have enabled and started cups services?

systemctl enable cups.service
systemctl start cups.service

A fresh reboot after installing the aur package maybe required as well.

2 Likes

[stephan@archlabs7700K ~]$ systemctl enable cups.service
[stephan@archlabs7700K ~]$ systemctl start cups.service
[stephan@archlabs7700K ~]$

following:

http://localhost:631/admin

Drucker hinzufügen
Drucker hinzufügen (Schritt 4/5)
Name: Brother_HL-L2360D_series
Beschreibung: Brother HL-L2360D series
Ort:
Verbindung: lpd://BRN30055C9F05F1/BINARY_P1
Freigabe: Drucker nicht im Netzwerk freigeben
Hersteller: DYMOEpsonFuji XeroxGenericHPIndexIntellitechOkiRawRicohZebra

Drucker hinzufügen (Schritt 5/5)
Name: Brother_HL-L2360D_series
Beschreibung: Brother HL-L2360D series
Ort:
Verbindung: lpd://BRN30055C9F05F1/BINARY_P1
Freigabe: Drucker nicht im Netzwerk freigeben
Hersteller: DYMO
Modell: DYMO Label Printer (en)

end end…, no printing… :frowning:

cu, stephan

Guess that you need to be a superuser ( not recommended ) , it was the only way that I had it to work a while ago, but don t know if it s still the same.

Edit1; Wonder if one has to add location on the 5th step also, never know.

Edit2; this also might help you out @volkmannold

https://aur.archlinux.org/packages/brother-hll2360dw-lpr-bin

1 Like

This the correct printer:

NZpBne.png

looks like only 32-bit drivers available; ArchLabs is 64-bit only. Does Xubuntu have the multilib packages installed?

1 Like

Is that for your ArchLabs or for your Xubuntu install @volkmannold

Xubuntu runs on my Thinkpad X220 and prints with both printers without problems.

I am looking for a solution for my Intel 7700K desktop computer running ArchLabs 2022.05.29

so for the rolling archlinux…

thanks for the tip @PackRat,
exactly the brother driver I have “Transformed” from deb to arch, seems that the 32bit theme is the problem.

Package: gcc-multilib-x86-64-linux-gnux32 (4:7.4.0-1ubuntu1.3 and others) [security] [universe].
seems so, doesn’t it?

That’s usually the case. My Brother printer drivers are 32-bit only; it’s basically a copier/scanner now. Both my HP printers work with 64-bit distros.

Is the Xubuntu computer always on? One thing you could try is running it as a print server. I’ve never done that with a printer that only has 32-bit drivers and a client without multilib installed, but I think it will work.

1 Like

My son thinks I should just connect the two printers to a Raspberry Pi 3 B, and the ethernet cable to the router.
Or connect the printers directly to my TBS-464 M.2 NVMe SSD NASbook with ethernet/usb cables.
Could work if the nasbook is not running archlinux :slight_smile:

2 Likes

Gee, that sux that you can t have it to work.

my son (born 1985) tells Kuka robots at the volkswagen plant in hannover how to assemble a VW ID 4.

he traffics three terminals on my archlabs pc at a crazy speed with inputs that i can’t even read that fast and certainly don’t understand.

but doesn’t get archlabs to print either :frowning:

as we were leaving he just said, dad, email me what you want to print, I can print it out at work and bring it to you.
I think he thinks I should chisel it in stone like I did before… Children :slight_smile:

1 Like

lol, still the best way I think !

uname -a
Linux mx2600k 5.10.0-16-amd64 #1 SMP Debian 5.10.127-1 (2022-06-30) x86_64 GNU/Linux
stephan@mx2600k:~

I am currently testing on my old 2600k MX - Linux, what can I say,
both printers spit out test pages right away without my “help”.
It’s kind of strange that archlinux / archlabs can’t manage this.

Postscriptum: My wife’s Zenbook (Win11) has now stopped printing.

lol

Well , better stick with what works I must say.

1 Like

On the PC I work with every day, Archlabs has been running for a long time, but I can’t print with it :slight_smile:

For this I have built an old PC and tested MX-Linux.
when I need to print something, I always have to start it up, which is a bit awkward…

Same here, can t print on my end, first after an update & secondly after a fresh install, but I m not needed it .