Powerline-shell [SOLVED]


#1

Hi

Very nice distro, it’s my favorite Bspwm/i3 distro at least. Well, let’s say that it’s my favorite tiling wm distro.

So, everything is just fine, but when i tried to add a little bling (powerline-shell) to my terminal, it didn’t work for some reason. I followed this tutorial. https://github.com/b-ryan/powerline-shell Pip installed the program and added the required lines in bash.rc, but no luck.

I’m on latest AL bspwm and i use Termite and Guake terminals.


#2

What shell are you using?

AL default is zsh, so you’ll need to add…

``

function powerline_precmd() {
    PS1="$(powerline-shell --shell zsh $?)"
}

function install_powerline_precmd() {
  for s in "${precmd_functions[@]}"; do
    if [ "$s" = "powerline_precmd" ]; then
      return
    fi
  done
  precmd_functions+=(powerline_precmd)
}

if [ "$TERM" != "linux" ]; then
    install_powerline_precmd
fi

… to your ~/.zshrc if using the default shell.


#3

It’s bash.


#4

Are you sure you’re not using zsh?


#5

Yes, i chose bash in the install. I guess i can switch to zsh and try with that.

EDIT: Didn’t work with zsh either.


#6

Ok, yeah I suppose you could. I’ve never used powerline-shell myself so perhaps someone more knowledgeable will be along shortly.


#7

I installed from AUR instead of pip.

Yes, my shell is zsh on this machine. I’ll check on another one.


#8

Arch & Bash:


#9

Ok, i got it to work in zsh, but now Neofetch is gone. :smiley: Oh well… Things must be pretty well, when you battle with this kind of a very minor problems. :stuck_out_tongue:

It says “zsh: command not found: neofetch”.


#10

Sounds like you just don’t have neofetch installed, try

baph -i neofetch

Or if you just want our status script (the default included) add this to the end of your shell rcfile

al-info

#11

You’re right, it wasn’t installed. I thought it was, because it showed fine in bash shell. I don’t know… Maybe it was some special “Archlabs Neofetch thing” that doesn’t work in other shells?

Anyway, now everything is ok, i have enough bling in my terminal. :stuck_out_tongue:

Thanks!


#12

Glad it’s sorted :slight_smile:

Is it possible you were confusing neofetch with ArchLabs’ in house info script (al-info)


#13

Glenn, that must be it. It looked like Neofetch, so i thought…


#14

Right on… Water under the bridge now :yum:

Funny, couple weeks ago… I was editing neofetch and no matter what I did, saw no change.

Then it dawned (like a hammer to the head) on me, I was editing neofetch but displaying al-info :joy: