Polybar workspace icons instead of roman letters? (bspwm)

Hi again!

I took a strange turn configuring bspwm, but now most things are working.
I finally got polybar to autostart and finally I have got workspace that I can move between (with great support from @archus and @PackRat )!!
I have roman numbers for workspace-indicators but in modules.conf there are iconic fonts. How do I get them to show?
I have checked that I have all fonts installed. (even the iconic)
One question-mark for Font Awesome 5 Brands! I only had the free installed it seems.
I have even downloaded a couple of iconic fonts and put them in ~/.config/polybar/. Linked from modules.conf.
I must be missing something but can not find out what!

Very thankful for a hint!

womp

Read fonts in polybar. It should have the information you’re looking for.

1 Like

Now I have read the whole polybar wiki. I understood about half of it.
As far as could understand there is nothing wrong with my polybar/polybar.config.
(debugging fonts in panel gave nothing for example)
Iconic fonts are showing everywhere (wifi, clock etc) except for workspaces. (and that is what I want to change).
I was not able to find out why my workspaces only shows roman numbers.
I also changed the order of the fonts. (font-0 = “Font Awesome 5 Brands:pixelsize=11;1”) and now the roman numbers look a bit different.

Maybe I have to do the changes in bspwmrc?
Yeees!! It was actually really simple!!
Just switched the roman numbers with glyphs using gucharmap!

Thanks for support!!

womp

1 Like

Good to see you’ve got everything working.

1 Like