Polybar stopped responding

After reboot, polybar works for a minute or two and then stops. Doesn’t respond to clicks, modules are frozen.

I ran

polybar -r i3-bar

and the second, working bar loads.

Any idea what’s going on?

not sure, what window manager are you using?

I’m using i3wm

Have you made any changes to your polybar config files?

Is it related to https://github.com/jaagr/polybar/issues/916

Do you click anything before it happens?

1 Like

What @malm asks is a good question. Possibly one of your modules is causing an issue. Can you please post your config @gorki.

Not sure what happened but the problem solved itself.

Before polybar started to play up, qpdfview crashed and took polybar with it. After that, every time I’d run qpdfview, polybar would freeze.

I tried to use MuPDF instead, no good. Tried to reinstall polybar, nothing.

I uninstalled both qpdfview and MuPDF and installed evince (light) instead and polybar is working fine now.

Background: I have done a fresh install from archlabs-2018.05.1.iso into VirtualBox on Win10Ent today,
I did not install any display managers or anything else during startup script

I am also expereincing the same problem where polybar is unresponsive
I did a few restarts, and it would work on startup and then stop again

I haven’t changed any settings (except repo update in /etc/pacman.conf)

What could I provide to help someone troubleshoot this?