Picom issue

im trying to set transparency for termite and i have done this on arch but i cant get it to work for anything this time around i set

opacity-rule = [“95:class_g = ‘Termite’”]; in picom.conf

and in i3

opacity-rule = [
“0:_NET_WM_STATE@:32a *= ‘_NET_WM_STATE_HIDDEN’”
];
which gives me a error

i even tried installing picom-git but when i type picom in terminal i get

% picom
[1] 4332 segmentation fault (core dumped) picom

any help?

I thought this was done through .config/termite/config. There’s I I have mine set and works well for me
I believe in mine, its this line:

background = rgba(40, 42, 54, 0.8) <— the 0.8

EDIT:
Never mind my post - I see what you are doing. I happened across the Arch Wiki and see what you were trying to do via i3.

yes the 0.8 is the transparency i just cant get it working for some odd reason and i dont understand what that error is when i run picom

You mean in your i3 config file? That’s not where that line goes. Should be in your picom.conf.

I have this in my picom.conf

opacity-rule = [
  "95:class_g = 'st-256color' && !_NET_WM_STATE@:32a",
  "0:_NET_WM_STATE@[0]:32a *= '_NET_WM_STATE_HIDDEN'",
  "0:_NET_WM_STATE@[1]:32a *= '_NET_WM_STATE_HIDDEN'",
  "0:_NET_WM_STATE@[2]:32a *= '_NET_WM_STATE_HIDDEN'",
  "0:_NET_WM_STATE@[3]:32a *= '_NET_WM_STATE_HIDDEN'",
  "0:_NET_WM_STATE@[4]:32a *= '_NET_WM_STATE_HIDDEN'"
];

and in the shadow-exclude section:

"_NET_WM_STATE@:32a *= '_NET_WM_STATE_HIDDEN'",

That’s what you’re attempting? Just change st-256color to Termite and see if it works.

What was the actual error message?

nope still not working

ok i dont get the error message anymore its because i put in the picom eample in there not the archlabs one they are in different directories but still its not working

ok sir i got it thank you for your help

Good.