PC stalled at “Reached target Graphical Interface” cannot boot

Im unsure what exactly has changed besides getting a new monitor, but I have no idea on what to do. I followed some steps on the arch forums, however while people had the same problem the symptoms weren’t the same so I’m stuck back at step one. I’ll post pics of any logs needed as I cannot upload them at this time.


Can’t find the edit button on mobile, I meant I’m unable to upload txt documents not pictures.

Installed nvidia-dkms and it did nothing. Reinstalled nvidia and now it’s stuck at “Started Accounts Service” progress I suppose?

It might have to do that you don t have the permission too or enough posts, maybe a mod will check it out @Nemoomen

Oh Im not really worried about the editing thing. Thank you though!

1 Like

Ah, no problem in there.

I know sometimes it can help to easily figure out things .

1 Like

Rebooted again. Back to being stuck at “reached target graphical interface”. Didn’t change a thing.

Checked Xorg log the last thing on the list is “NVIDIA(GPU-0): Deleting GPU-0” which. Probably isnt good. Either its using Xorg when it shouldn’t or Xorg itself is messed up.

Just be patient, someone in the know will chim in .

By the way, what s your hardware @Nemoomen

Oops sorry bout the spam, wanted to keep up-to-date info on what I’ve tried.

Kernel: 6.1.12-arch1-1
Cpu: AMD Ryzen 5 3500 (6) @ 3.600GHz
Gpu: NVIDIA GeForce GTX 1650 SUPER
Memory: 16gb

You may need,

nvidia-470xx-dkms from AUR

or, use the open source nouveau driver.

Tried both, nvidia 470 freezes on the same spot on boot and nouveau has been marked out of date since 2016 and requires a much older version of Linux. Thanks for the suggestion!

A couple of links to try.


Also make sure you have this file.

Pretty sure nvidia now users 20-nvidia.conf not xorg.conf

Good luck

Now we’re getting somewhere. I don’t have a 20-nvidia.conf file and running nvidia-xconfig doesn’t add one. I tried copying the xorg.conf to said file based on another thread I had found and it ultimately did nothing.

This is one I used years ago.

Section “Device”
Identifier “Nvidia Graphics”
Driver “nvidia”
Option “TearFree” “true”

Try running this command = lspci -k | grep -A 2 -E “(VGA|3D)”

lspci -k | grep -A 2 -E “(VGA|3D)”
09:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] (rev ca)
Subsystem: Sapphire Technology Limited Radeon RX 5600 XT
Kernel driver in use: amdgpu

Good Luck

Ran the command, output is:

0c:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1650 SUPER] (rev a1)
Kernel modules: nouveau, nvidia_drm, nvidia

I will try updating the 20- file with the info provided

What desktop/window manager are you trying to boot to, and are you using a login manager?

You may need to blacklist that nouveau module. I’ve had to do that in the past.


Thanks everyone for all your help. Unfortunately I’m on a time crunch due to this being a work machine so I’m forced to reinstall Archlabs.

After some sleep the only thing I can think that caused this mess was me changing graphics settings within the nvidia control panel and something blew up.

Thanks again!