Pacman 6 - New release

Hi folks the new pacman 6 is now out but will break some of the aur helpers.
To get yay working again I had to delete yay and rebuild.
Working again as expected. :+1:

2 Likes

Mine works fine.

yay broke for me on a Arch and Archlabs install.
I see on other sites some of the other aur helpers are down as well.

1 Like
⋊> ~ pacman -V                                                                                                                                                              0
 .--.                  Pacman v6.0.0 - libalpm v13.0.0
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2021 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.
⋊> ~ yay -V                                                                                                                                                                 
yay v10.2.2 - libalpm v13.0.0

pamac-aur is broken, maintainer says he’ll get to it but is to busy. Guess I can’t be lazy for a bit…LOL

2 Likes

If you update to pacman 6 using yay it will now pull in the updated yay. As for me I took the update before yay was updated. A simple reinstall of yay fixed things for me.

1 Like

Must be the case. The system was updated this morning.

1 Like

Yes it does. Just updated using yay and all works as expected. Thanks for the heads-up!

1 Like

Seems not to have affected my trizen.

1 Like
~ % pacman -V

.–. Pacman v6.0.0 - libalpm v13.0.0
/ _.-’ .-. .-. .-. Copyright (C) 2006-2021 Pacman Development Team
\ '-. ‘-’ ‘-’ ‘-’ Copyright (C) 2002-2006 Judd Vinet
‘–’
Ce programme peut être librement redistribué
sous les termes de la licence GNU GPL.

mic@archlabs ~ % yay -V
yay: error while loading shared libraries: libalpm.so.12: cannot open shared object file: No such file or directory

Rebuild yay:

yay v10.2.2 - libalpm v13.0.0

2 Likes

yay v10.2.2-libalpm v13.0.0
yay: error while loading shared libraries: libalpm.so.12: cannot open shared object file: No such file or directory

All I did was remove the directory yay and run the following code.

pacman -S --needed git base-devel
git clone https://aur.archlinux.org/yay.git
cd yay
makepkg -si

3 Likes

It’s ok, thank you.

1 Like

No !!! Impossible to open pacman…

Am I understanding you correctly, pacman will not open for you?

2 Likes

pacman or pamac?

Just ran pacman -Syu with no issues, upgraded gnutls and imagemagick.

pamac is dead in the water for now.

2 Likes

Ok I’ll wait… ( sorry, pamac )

2 Likes

No problem, that’s what I thought.

2 Likes

I read paru has now been updated to work with the latest pacman.

1 Like