org.freedesktop.Dbus and rfkill ask for root password post booting

Dear All,

I am running Archlabs linux on a Lenovo Thinkpad x220i. When I boot, the boot process goes smoothly; the machine boots into Archlabs linux and shows the wallpaper etc. After five seconds, two prompts pop up asking for root password. If I do not fill in the password and then click on the “description” link on the pop-up box, it states “org.freeDesktop.DBus.NoReply bluetooth error” and the second one states “Rfkill”. I searched Archlabs forum and Archwiki and related forum posts but could not find an exact answer or replication of the issue. It is not an error in the sense if I enter root password then bluetooth and wifi work as expected, so it is not an error, but if I did not want to see the password prompt, what would I do? I tried setting the ~/.xinitrc to something like:
exec /usr/bin/openbox-session but that did not work.
Would greatly appreciate if you can kindly explain as to why such a password prompt pops up post booting and what should I do so that I do not have to see that prompt.

Best,
Arindam Basu

in my opinion you have to create a non-root user, but maybe I’m wrong.
user management
https://wiki.archlinux.org/index.php/Users_and_groups

1 Like

Thanks @ector for the suggestion about non-root user. Here’s what solved it:

  1. I had to check that I was part of the wheels group (Archlabs added me already so I did not have to do anything)
  2. I found that I had to create a file sudo nano /etc/polkit-1/51-blueman.rules and add the following lines of code:
/* Allow users in wheel group to use blueman feature requiring root without authentication */
polkit.addRule(function(action, subject) {
    if ((action.id == "org.blueman.network.setup" ||
         action.id == "org.blueman.dhcp.client" ||
         action.id == "org.blueman.rfkill.setstate" ||
         action.id == "org.blueman.pppd.pppconnect") &&
        subject.isInGroup("wheel")) {

        return polkit.Result.YES;
    }
});

The details are here: https://wiki.archlinux.org/index.php/Blueman#Permissions

1 Like