Openbox window decorations

Hi Archlabers!

I have managed to install Archlabs on an old Mac-mini (4,1 2010).
I have a problem with window decorations being too small and thin. I have changed values in themerc (border, osd border etc) but nothing happens. Obmenu-generator is also very very small (unreadable). It seems to be system wide.
I may have had this issue before but can’t remeber the solution.

I hope someone has mercy with a confused oldie

womp

What’s the resolution of the monitor set at?

Resolution 1920x1080

womp

A screenshot would probably help here.

I have a “HiDPI” openbox theme with oversized decorations that might help:

mkdir -p ~/.local/share/themes
mkdir -p ~/git && cd ~/git
sudo pacman -S git
git clone https://github.com/head-on-a-stick/sharp-configs
cp -r sharp-configs/usr/share/sharpbang/skel/.local/share/themes/* ~/.local/share/themes

Then select “Greybird-HiDPI” as the theme.

Copy the .xbm files from ~/.local/share/themes/Greybird-HiDPI/ to your favoured theme to apply them there as well. Or make your own in GIMP; the size of the xbm grid sets the size of the decoration.

^ something like this.

Search HDPI on the forum. There were some other users that had similar issues.

Here is a shot.
If you look to the right … closely you will see obmenu.

womp

I will search for hidpi!
I have been searching for “window decoration”, “window border”, “gtk-qt-problems” and tried 6 different “solutions”. No real solution found though!

womp

The GTK scaling looks off there. Far too large. Maybe it’s just me?

1 Like

Can we see

xdpyinfo | grep dots
grep -A2 "<font" ~/.config/openbox/rc.xml
grep "gtk-font-name" ~/.gtkrc-2.0

xdpyinfo | grep dots resolution: 96x96 dots per inch

grep -A2 "<font" ~/.config/openbox/rc.xml
 <font place="ActiveWindow">
      <name>sans</name>
      <size>11</size>

    <font place="InactiveWindow">
      <name>sans</name>
      <size>11</size>

    <font place="MenuHeader">
      <name>sans</name>
      <size>11</size>

    <font place="MenuItem">
      <name>sans</name>
      <size>10</size>

    <font place="ActiveOnScreenDisplay">
      <name>sans</name>
      <size>10</size>

    <font place="InactiveOnScreenDisplay">
      <name>sans</name>

grep “gtk-font-name” ~/.gtkrc-2.0

gtk-font-name=“monospace 11”

Hi everyone, I don’t have any gtk-2 in Home, I have one in .config and without gtk-font-name.
Do I have to have this on Home ?!
gtk-font-name is there only in gtk-3 always in .config

Hi again great guys and great forum!!

I have been looking at hidpi a couple of hours and found a solution here!
I went to .Xresources and edited with Xft.dpi 112. (tried many other values!)

Thank you all and thank you PackRat for your suggestion!

womp

1 Like

Glad that you got it fixed @womp

Props to @PackRat @Head_on_a_Stick

Thanks man!
I think I got this problem because of a new screen.
Had no idea that .Xresources could make such a difference!

womp

Oh, some new goodies ! Cool.

Didn t know either!

Yeah! Forum is filled with knowledge now!

womp

Lol, we re lucky to have some knowledgeable members around !

Absolutely!

womp

No. Both gtk-2.0 and gtk-3.0 should be in ~/.config.

I think ArchLabs uses xfce4-session to set the themes & fonts rather than ~/.gtkrc-2.0.